Bug 6741 - ps2 mouse locking up system during install and X startup
ps2 mouse locking up system during install and X startup
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-04 21:00 EST by jody
Modified: 2015-01-07 18:39 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-30 08:29:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jody 1999-11-04 21:00:27 EST
The problem goes far beyond the simplistic "mouseconfig"
solution.  I have 2 pc's 1-a Gateway that is impossible and
2 a Compaq that installed flawlessly after giving up in
total futility on the Gateway.  I need this to work on the
Gateway, for work.  I've tried everything on the web help
guides(see following text.)  I tried ALL the mice
in "mouseconfig".  I tried a Logitech Mouseman and a
Microsoft intellimouse.  I tried turning the COM ports on
and off in BIOs.  Switched around the IRQ's.  I stopped
short of pulling boards out of the PC.  This IS a mouse not
a Telemetry board for the X-33.  If this were a Compaq
giving me these problems I'd be ok, I work for them and
have close ties to Unix Engineering.  What is different in
the GATEWAY.  What information can I collect on the Linux
command line to help you diagnose why it won't recognize
the mouse?  Thanks -- Joe D'Agostino

SUGGESTED SOLUTION:
At 11/4/99 4:28 PM we wrote -
Hi,

You would need to run the "mouseconfig" utility and specify
your mouse.

INCIDENT DETAILS:
         Reference #:  991103-0009
             Product:  Red Hat Linux/Intel 6.0
            Category:  Bugs and other Problems
        Contact info:  jody@jdagosti.mv.com
        Time created:  11/3/99 6:32 PM
        Last updated:  11/4/99 4:28 PM
        Elapsed time:  21 Hours, 56 Minutes
              Status:  Unresolved
        Registration:  a8d45c8eddf055ac
E.8.13 I have a Microsoft serial mouse, and Linux doesn't
want to work with
it. What can I do to fix it?

It has been found that the 2 button Microsoft Mouse of
version 2.1A or
greater is a "smart" mouse. It has been speculated that it
is looking for
wakeup signals from Windows, or it will not respond back to
the computer.
This causes X and/or gpm to not work with Linux because the
mouse is not
responding in a way these programs are expecting.
To "reset" the mouse to
work with these programs, you can follow one of several
methods. Use
mouseconfig to set things up before running X.
mouseconfig --kickstart  --device cuaX
where X is either 0 (for com 1) or 1 (for com2)
Another solution is to get gpm-1.13, run as gpm -t pnp -R,
and configure
XFree86 for MouseSystems Protocol with /dev/gpmdata as the
device.

Joseph D'Agostino
Senior Software Engineer
Compaq Computer Corporation
Comment 1 Jay Turner 1999-11-30 08:29:59 EST
I am a little confused :-(  The subject says that this is a problem witha  ps/2
mouse, and the description is talking about a serial mouse.  Second, the first
part of the description is talking about problems with a MS mouse, and then the
second part is giving what looks to be a pretty good solution to the problem.

Was this submitted to inform us of the resolution to the problem??  If so, then
thanks!!! . . . we will add it to the knowledge database.

If there is still a problem, then please reopen this bug and let us know more
details of what the problem is.

Thanks,
J
Comment 2 jody 1999-11-30 18:33:59 EST
Ok, Sorry for the confusion.  The problem still exists.  All I was trying to
say was I've tried everything and the mouse still doesn't work.  Should I write
Gateway computers and ask why it doesn't work?

What information can I collect on the Linux command line to help you diagnose
why it won't recognize the mouse?

Note You need to log in before you can comment on or make changes to this bug.