Bug 674105 - IOException: Partition map has no partition map entry!
IOException: Partition map has no partition map entry!
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:e6b02d105481b095d...
:
Depends On:
Blocks: F15Beta/F15BetaBlocker
  Show dependency treegraph
 
Reported: 2011-01-31 11:46 EST by Brett Williams
Modified: 2011-06-09 10:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-24 09:53:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (191.54 KB, text/plain)
2011-01-31 11:46 EST, Brett Williams
no flags Details
Attached traceback automatically from anaconda. (562.40 KB, text/plain)
2011-06-09 03:50 EDT, stainedshuriken
no flags Details

  None (edit)
Description Brett Williams 2011-01-31 11:46:28 EST
The following was filed automatically by anaconda:
anaconda 14.22 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/parted/disk.py", line 213, in commit
    return self.__disk.commit()
  File "/usr/lib64/python2.7/site-packages/parted/decorators.py", line 31, in localeC
    ret = fn(*args, **kwds)
  File "<string>", line 2, in commit
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/disklabel.py", line 248, in commit
    self.partedDisk.commit()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 1390, in destroy
    self.disk.originalFormat.commit()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 219, in execute
    self.device.destroy()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 700, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 313, in doIt
    self.devicetree.processActions()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packages.py", line 110, in turnOnFilesystems
    anaconda.storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 212, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 131, in gotoNext
    self.moveStep()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1278, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1191, in nextClicked
    self.setScreen ()
IOException: Partition map has no partition map entry!
Comment 1 Brett Williams 2011-01-31 11:46:33 EST
Created attachment 476228 [details]
Attached traceback automatically from anaconda.
Comment 2 Brett Williams 2011-01-31 11:51:23 EST
I have been trying to install Fedora 14 on a box that used to be running Fedora 9.  The reason for the upgrade, besides wanting to get current, was that the old hard drive failed.  I have installed a new hard drive...

I am getting an "unhandled exception" error every time I try to partition the drive.  I have tried manually partitioning, letting the installer choose the partitioning and then modifying it myself, and just letting the installer do its own thing.  All of them keep generating an error.

Thinking that maybe there was something buggy about Fedora, I tried doing an install of Fedora 13 and got the some result.  Something isn't making sense...
Comment 3 Brett Williams 2011-02-06 15:31:23 EST
Not sure what else to do at this point.  I have tried Fedora 12, 13 and 14 now all doing the same thing.  I have tried different SATA ports on the motherboard, different SATA cables and have done a full diagnostic on the drive...  None of them are showing a problem.

This is a Seagate 1TB drive, brand new...
Comment 4 Brett Williams 2011-02-06 16:19:38 EST
Got past the problem, although I don't know quite yet what the problem was...

Booted a F14 Live image.  Formatted the drive, rebooted with full F14 install DVD and it accepted the partitioning information and applied the changes and moved on...
Comment 5 Chris Lumens 2011-02-07 10:39:20 EST
Did the drive have anything like an empty partition table on it to begin with?
Comment 6 Brian Lane 2011-02-07 20:36:51 EST
It looks like it has a mac partition table on it and the storage action tries to remove the partition before making a new disklabel:

05:37:55,142 DEBUG storage: action: Destroy Device partition sda1 (id 5)
05:37:55,142 DEBUG storage: action: Destroy Format disklabel on disk sda (id 3)
05:37:55,142 DEBUG storage: action: Create Format disklabel on disk sda (id 3)
05:37:55,142 DEBUG storage: action: Create Device partition sda1 (id 7)

If it's going to make a new disklabel it should skip removing the partitions since they are going away anyway.
Comment 7 Brett Williams 2011-02-08 16:32:40 EST
(In reply to comment #5)
> Did the drive have anything like an empty partition table on it to begin with?

There was a small default partition on the drive when I opened the drive up in FC14 Live...  I didn't think to copy down the particulars since I was just going to blow it out...
Comment 8 David Lehman 2011-02-15 15:24:25 EST
The magic apple partition (aka: partition map entry) is supposed to have the name "Apple". Yours does not, which is why we are failing to recognize it for what it is. I am proposing a patch to remove the check for the name.

If your machine is a mac, please ignore the remainder of this comment.

If your machine IS NOT a mac I would recommend that you create a more appropriate disklabel on your disk. You can do this by running the following command as root in a shell:

  WARNING: if you're on a mac machine you probably do not want to run this

    parted /dev/sda mklabel msdos
Comment 9 David Lehman 2011-02-15 15:47:24 EST
This is nothing too critical since most times a MAC disklabel will have the name set correctly for the Apple partition map entry, but we aren't gaining anything by requiring that the name be set to "Apple".

The above assumes there is no case where a MAC disklabel can have a first partition that is anything other than the magic partition map partition.
Comment 10 Brett Williams 2011-02-16 10:04:33 EST
Well, I am not sure where all the discussion regarding MAC has come into this...  I am not running on an Apple.  This was a home built machine that I rune MythTV on and the old hard drive died.  I went out and bought a new (sealed) Seagate 1TB drive and popped it in the box and started the install.

I am unaware of how Seagate pre-partitions their hard drives, but in the install process I told it to blow out the old partitioning to start from scratch and was still getting the error.
Comment 11 David Lehman 2011-02-16 11:32:44 EST
Your disk came set up for use on a Mac. The error/failure occurred while we were in the process of clearing its contents.

You can work around the issue by running the command from the end of comment 8.
Comment 12 David Lehman 2011-02-24 09:53:44 EST
Fix will be in anaconda-15.21-1.
Comment 13 stainedshuriken 2011-06-09 03:50:04 EDT
Created attachment 503840 [details]
Attached traceback automatically from anaconda.
Comment 14 David Lehman 2011-06-09 10:54:48 EDT
(In reply to comment #13)
> Created attachment 503840 [details]
> Attached traceback automatically from anaconda.

Your problem is completely unrelated to the issue described in this bug report.

Have you considered trying a Fedora 15 livecd instead of the Fedora 14 livecd you are currently using?

Note You need to log in before you can comment on or make changes to this bug.