Bug 67415 - suggestion for tar documentation
Summary: suggestion for tar documentation
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: tar (Show other bugs)
(Show other bugs)
Version: 2.1
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-24 18:53 UTC by Robert Nagle
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-15 10:06:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Nagle 2002-06-24 18:53:26 UTC
I have a suggestion for documentation about tar (man, info). 

I just learned today that when root uses tar the ownership of untarred files 
will by default revert to the user who tarred the file in the first place. When 
downloading a tarred binary, that could be a problem because the uid for the 
files might not correspond on different systems. 

The man page should contain a sentence or two about ownership of extracted 
files. The info pages contain a short paragraph about it under "option 
summary", (--owner=USER), but I think it needs more prominent mention. 

Imagine my frustration when root was untarring something and all the untarred 
files belonged to a user I hardly used anymore.

Comment 1 Peter Vrabec 2004-12-15 10:06:17 UTC
info tar

`--no-same-owner'
     When extracting an archive, do not attempt to preserve the owner
     specified in the `tar' archive.  This the default behavior for
     ordinary users; this option has an effect only for the superuser.



Note You need to log in before you can comment on or make changes to this bug.