Bug 6742 - SEGFAULT in PyDict_New() while python script. No error after Python is compiled from SRPM
SEGFAULT in PyDict_New() while python script. No error after Python is compil...
Product: Red Hat Linux
Classification: Retired
Component: python (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Depends On:
  Show dependency treegraph
Reported: 1999-11-04 21:46 EST by pogosyan
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-12-20 16:00:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description pogosyan 1999-11-04 21:46:55 EST
I use FortyTwo.py script from

It worked find under RH5.2 but fails with segmentaion fault
in PyDict_New() after upgrade to RH6.0. This persists after
I upgraded to python-1.5.2-7 from RH6.1
GDB trace follows. What is interesting, the program works
fine if I download python-1.5.2-7.src.rpm and compile it
manually, enabling Tcl/Tk support

GDB output
myprompt> gdb /usr/bin/python
(gdb) run
>>> execfile("/usr/local/lib/FortyTwo/FortyTwo.py")
Traceback (innermost last):
  File "<stdin>", line 1, in ?
  File "/usr/local/lib/FortyTwo/FortyTwo.py", line 460, in ?
    from FWidgets import *
ImportError: No module named FWidgets

or analyzing the coreTraceback (innermost last):
prompt> gdb /usr/lib/python core
Core was generated by
#0  0x806fc42 in PyDict_New ()
Comment 1 Michael K. Johnson 1999-11-22 14:00:59 EST
I have no vgetty settup, but I do have a question first: have you tried
using the gtk widget set instead of the tk widget set?
Comment 2 Nalin Dahyabhai 1999-12-20 16:00:59 EST
Please see if this is fixed in python-1.5.2-9 or later from RawHide, and let me
know either way.
Comment 3 Brent Fox 2002-06-05 00:54:40 EDT
This is bound to have been fixed by now.

Note You need to log in before you can comment on or make changes to this bug.