Bug 674234 - Regression: groupadd dumps with large groups
Regression: groupadd dumps with large groups
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
14
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
:
Depends On: 674361
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-01 00:30 EST by Eric Biederman
Modified: 2011-02-02 14:37 EST (History)
2 users (show)

See Also:
Fixed In Version: shadow-utils-4.1.4.2-10.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-02 14:37:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Biederman 2011-02-01 00:30:07 EST
Description of problem:
/usr/sbin/groupadd dumps core when groups with large memberships are present.

Version-Release number of selected component (if applicable):
shadow-utils-2:4.1.4.2-9.fc14.x86_64

How reproducible:
- Create a group line longer than than 1024 bytes

Removing
shadow-4.1.4.2-gshadow.patch

from set of patches that are compiled in when building the rpm makes the problem go away.
Comment 1 Fedora Update System 2011-02-01 11:30:33 EST
shadow-utils-4.1.4.2-10.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/shadow-utils-4.1.4.2-10.fc14
Comment 2 Peter Vrabec 2011-02-01 11:36:06 EST
I have adjusted shadow-4.1.4.2-gshadow.patch in a way it does not enable gshadow functions from glibc in shadow-utils. This is a workaround, because the real problem here is bug in glibc (#674361)

Related bug (665780)
Comment 3 Fedora Update System 2011-02-01 15:55:10 EST
shadow-utils-4.1.4.2-10.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update shadow-utils'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/shadow-utils-4.1.4.2-10.fc14
Comment 4 Fedora Update System 2011-02-02 14:36:57 EST
shadow-utils-4.1.4.2-10.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.