Bug 67431 - Kernel's after 2.4.7-10 cause random X glitches making X unusable
Kernel's after 2.4.7-10 cause random X glitches making X unusable
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-24 22:19 EDT by Shawn D. Kelly
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-09 23:46:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shawn D. Kelly 2002-06-24 22:19:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705)

Description of problem:
I have an ABit SE6 with Intel 815E integrated graphics & audio.  Initially, I 
thought this was a RH 7.3 issue since it happened immediately after installing 
and didn't happen on RH 7.2 or Mandrake 8.2.  However, after more testing, it 
also happens under RH 7.2 if I update the kernel past the base 2.4.7-10.

What happens: Upon logging into KDE, all seems well at first.  After a short 
period of time, the screen will simple go black andc I'll be back at the login 
prompt for X.  Under GNOME, application and bus errors will popup for anything 
running and I'll be lucky if I can get it to log out.

I currently have both the 2.4.7-10 and 2.4.9-34 kernel's installed and can run 
flawlessly under the 2.4.7-10.  If I boot into the 2.4.9-34, it will 
immediately start going crazy.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Load into Kernel 2.4.9-34
2. Run Theme Selector under GNOME and select a theme
3. Use the arrow keys to flip through all the themes and within 1 minute, 
everything goes haywire.
	

Actual Results:  GNOME: Window title bars disappeared, any opened programs I 
could get to appear would appear in upper left w/o titlebar, panel sometimes 
disappears, taskbar flashes programs on and off, bus and application errors 
pop up.

Expected Results:  Nothing - it should work without issue as it does under 
kernel 2.4.7-10

Additional info:
Comment 1 Mike A. Harris 2002-07-09 22:36:23 EDT
What XFree86 version-release are you using?  Please attach your X server
log and config file.  If you're not already using all released errata
updates, please update your system with up2date and provide new information
in the bug report also.

Thanks.
Comment 2 Shawn D. Kelly 2002-07-09 23:46:39 EDT
Ok... no problem.  I'll post the logs shortly... but as for the errata 
updates, all are installed.

Thanks.
Comment 3 Mike A. Harris 2002-11-04 06:34:04 EST
You never did attach those logs...

At any rate, the Intel i8x0 kernel DRM code was changed by Intel in an
ABI incompatible way, which broke the driver.  It's released and in
production, so there is no way to properly "fix" it.  Many great thanks
to Intel for this wonderfulness.

Anyway...  Our latest kernel has an ugly hack workaround for this issue
by plopping some crap in /etc/modules.conf which instructs the kernel
which ABI to use.  The kernel keeps both ABI's present internally, and
if modules.conf is set correctly, it should work properly.  This same
issue occurs for Red Hat Linux 7.3 and 8.0 also.

DRI developers have since discovered another hackish way they can
autodetect this at runtime somehow and XFree86 4.3.0 should come with
this code by default.  We might backport the fix as well, but since
it is quite nasty, we might just leave it with our existing hack that
seems to work.

If you still experience these problems even after applying the latest
erratum to 7.[123] or 8.0, please reopen the bug report if you like.
Comment 4 Shawn D. Kelly 2002-11-04 11:08:40 EST
I apologize for not following up on this... I ended up dropping Linux because 
of the issue and haven't touched it since... I may in the future pick it up 
again and explore some more but right now, I do not have the time.

Thanks again.
Comment 5 Mike A. Harris 2002-11-05 04:38:46 EST
Ok, if you start using Linux again (c'mon, you know you want
to <grin>) and the problem manages to pop up for some reason, please
reopen this report if you like, or file a new one against the newest
release.

Thanks again,
TTYL

Note You need to log in before you can comment on or make changes to this bug.