Bug 674311 - [abrt] crash in freetype's _lcd_stem_align
Summary: [abrt] crash in freetype's _lcd_stem_align
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 14
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c52afa88c39fb0aa4870d02e4e3...
: 678254 684604 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-01 12:27 UTC by Kazimieras Vaina
Modified: 2011-03-14 08:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-01 13:44:58 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (82.58 KB, text/plain)
2011-02-01 12:27 UTC, Kazimieras Vaina
no flags Details

Description Kazimieras Vaina 2011-02-01 12:27:52 UTC
abrt version: 1.1.14
architecture: i686
Attached file: backtrace
cmdline: /usr/lib/openoffice.org3/program/scalc.bin -calc
comment: I was trying to open a spreadsheet on nfs file system.
component: openoffice.org
crash_function: _lcd_stem_align
executable: /usr/lib/openoffice.org3/program/scalc.bin
kernel: 2.6.35.10-80.fc14.i686
package: openoffice.org-calc-1:3.3.0-19.2.fc14
rating: 4
reason: Process /usr/lib/openoffice.org3/program/scalc.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1296561640
uid: 502

How to reproduce
-----
1.locate file with file browser (nautilus)
2.open with ooo
3.

Comment 1 Kazimieras Vaina 2011-02-01 12:27:55 UTC
Created attachment 476377 [details]
File: backtrace

Comment 2 Caolan McNamara 2011-02-01 12:41:23 UTC
Nothing to do with nfs itself. A crash in rendering text in libfreetype. Can't tell if its a freetype bug or a OOo one by handing it broken data.

(https://bbs.archlinux.org/viewtopic.php?pid=864993)

Can you reproduce this by opening the same document again ? Its like the the combination of fonts installed and the fonts requested by a particular document trigger this.

Comment 3 Kazimieras Vaina 2011-02-01 13:15:35 UTC
I see... 

Actually it seems that I can not start a oocalc at all. I tired with -norestore as well.

I might related with "infinality" freetype I have installed from: http://www.infinality.net/fedora/linux/14/i386/

I guess I shall revert to stock Fedora freetype package ?

Comment 4 Kazimieras Vaina 2011-02-01 13:42:04 UTC
After I reverted freetype package the oocalc started working again - Thanks a lot !

Comment 5 Kazimieras Vaina 2011-02-01 13:44:58 UTC
I think we can close this bug as it's third-party software issue.

Comment 6 Kevin Kofler 2011-02-17 15:51:39 UTC
This is already reported at: http://www.infinality.net/forum/viewtopic.php?f=2&t=48
They have a fix, but unfortunately, they still haven't fixed the RPMs.

Comment 7 Kevin Kofler 2011-02-17 15:53:21 UTC
*** Bug 678254 has been marked as a duplicate of this bug. ***

Comment 8 David Tardon 2011-03-14 08:46:13 UTC
*** Bug 684604 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.