Bug 674330 - [abrt] openoffice.org-calc-1:3.2.0-12.33.fc13: SfxViewShell::GetController: Process /usr/lib64/openoffice.org3/program/scalc.bin was killed by signal 11 (SIGSEGV)
Summary: [abrt] openoffice.org-calc-1:3.2.0-12.33.fc13: SfxViewShell::GetController: P...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 13
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:05ca9ad4063d4d71652bc709ffa...
: 633633 680128 680240 680957 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-01 13:57 UTC by Leonardo Brenta
Modified: 2011-03-09 03:15 UTC (History)
4 users (show)

Fixed In Version: libreoffice-3.3.1.2-3.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-09 03:15:37 UTC


Attachments (Terms of Use)
File: backtrace (55.07 KB, text/plain)
2011-02-01 13:57 UTC, Leonardo Brenta
no flags Details

Description Leonardo Brenta 2011-02-01 13:57:32 UTC
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/openoffice.org3/program/scalc.bin -calc file:///home/lbrenta/.evolution/cache/tmp/evolution-lbrenta-wUZko2/fecha_DDJJ_por_envios_mulat.xls
component: openoffice.org
crash_function: SfxViewShell::GetController
executable: /usr/lib64/openoffice.org3/program/scalc.bin
kernel: 2.6.34.7-66.fc13.x86_64
package: openoffice.org-calc-1:3.2.0-12.33.fc13
rating: 4
reason: Process /usr/lib64/openoffice.org3/program/scalc.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)
time: 1296566211
uid: 500

How to reproduce
-----
1.
2.
3.
0

Comment 1 Leonardo Brenta 2011-02-01 13:57:36 UTC
Created attachment 476402 [details]
File: backtrace

Comment 2 David Tardon 2011-02-01 15:01:41 UTC
*** Bug 633633 has been marked as a duplicate of this bug. ***

Comment 3 David Tardon 2011-02-01 15:03:02 UTC
What were you doing when the crash happened?

Comment 4 Caolan McNamara 2011-02-16 16:43:08 UTC
#3 has a this of 0, #4 has a dereference of mpBase followed later on with a check to see if mpBase is NULL.

Could hazard a band-aid fix based on that.

Comment 5 Caolan McNamara 2011-02-16 16:54:36 UTC
bandaid will be in >= 3.2.0-12.36 if we do another update for F-13

Comment 6 Fedora Update System 2011-02-17 08:50:39 UTC
libreoffice-3.3.1.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libreoffice-3.3.1.1-1.fc15

Comment 7 Fedora Update System 2011-02-17 22:25:50 UTC
libreoffice-3.3.1.1-1.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libreoffice'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/libreoffice-3.3.1.1-1.fc15

Comment 8 Caolan McNamara 2011-02-24 13:59:32 UTC
*** Bug 680128 has been marked as a duplicate of this bug. ***

Comment 9 Caolan McNamara 2011-02-24 21:26:01 UTC
*** Bug 680240 has been marked as a duplicate of this bug. ***

Comment 10 Caolan McNamara 2011-02-24 21:27:24 UTC
Strangely large number of test recently. This "fix" here is only a local bandaid to the immediate place it crashes, is anyone able to provide a sure-fire route to reproduce this crash in order to get a real fix ?

Comment 11 David Tardon 2011-02-28 18:15:43 UTC
*** Bug 680957 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Update System 2011-03-03 17:20:01 UTC
Package libreoffice-3.3.1.2-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.3.1.2-3.fc15'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/libreoffice-3.3.1.2-3.fc15
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2011-03-09 03:15:13 UTC
libreoffice-3.3.1.2-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.