This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 674334 - /usr/bin/dig has problem on dualstacked system
/usr/bin/dig has problem on dualstacked system
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
13
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-01 09:24 EST by Svante Victorsson
Modified: 2013-04-30 19:48 EDT (History)
2 users (show)

See Also:
Fixed In Version: bind-9.7.3-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-26 23:50:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Svante Victorsson 2011-02-01 09:24:42 EST
Description of problem:
using /usr/bin/dig to analyse dns tree. When quering for hostrecord its no problem.
When +trace is used /usr/bin/dig is unable to resolve query.

Version-Release number of selected component (if applicable):
DiG 9.7.2-P3-RedHat-9.7.2-1.P3.fc13

How reproducible:
dig 1.11.228.81.in-addr.arpa   PTR  - resolves correctly
dig 1.11.228.81.in-addr.arpa   PTR +trace - unable to resolve

Steps to Reproduce:
1. try to query normal dig - resolves as expected
2. try to trace dns tree - hangs
3.
  
Actual results:

+trace makes dig timeout

Expected results:

Should work

Additional info:
My system is dual stacked. I think that has something to do with it.
however, using -4 option to /usr/bin/dig it resolves nicely.
Comment 1 Svante Victorsson 2011-02-18 08:28:28 EST
Anyway, after much debugging/trubbelshooting, the problem is solved. Apparently it was a router in the network, which stopped the returnig udp packets. But think it still is strange that /usr/bin/dig would not resolv because it "knows" that there are IPv4 connectivity. But perhaps it is another matter.


case closed.

 -- Svante
Comment 2 Adam Tkac 2011-02-18 08:32:06 EST
You are right there is a bug in the dig utility which prevents +trace working correctly.

You can trigger this bug when your machine is in the IPv6 LAN but this LAN has IPv4-only connectivity to Internet. In this case dig +trace fails as you wrote above and "-4" parameter is a workaround.
Comment 3 Fedora Update System 2011-02-18 10:30:44 EST
bind-9.7.3-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/bind-9.7.3-1.fc14
Comment 4 Fedora Update System 2011-02-18 10:31:06 EST
bind-9.7.3-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/bind-9.7.3-1.fc15
Comment 5 Fedora Update System 2011-02-18 10:31:28 EST
bind-9.7.3-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/bind-9.7.3-1.fc13
Comment 6 Fedora Update System 2011-02-18 20:22:30 EST
bind-9.7.3-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bind'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/bind-9.7.3-1.fc14
Comment 7 Fedora Update System 2011-02-26 23:50:18 EST
bind-9.7.3-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2011-03-01 20:47:10 EST
bind-9.7.3-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2011-03-02 22:06:02 EST
bind-9.7.3-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.