Bug 67435 - Wrong Filesize if FS > 2GB
Wrong Filesize if FS > 2GB
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Chip Turner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-25 00:08 EDT by StK
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-25 00:08:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description StK 2002-06-25 00:08:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Perl reports a wrong Filesize when the File > 2 GB
Try 
perl -e '@s=stat("/path/to/large/file"); print "size = $s[7]\n"'

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  locate a File > 2 GB
2.  Type in
3.  perl -e '@s=stat("/path/to/large/file"); print "size = $s[7]\n"'
	

Actual Results:  nothing is reported... so Programms using this report a 
filesize 0.
I actually deleted a file thinking it is empty

Expected Results:  Giving me the right Filesize

Additional info:
Comment 1 Chip Turner 2002-06-25 12:27:30 EDT
Perl in RHL 7.x doesn't support files larger than 2gb because of binary
compatibility issues.

Note You need to log in before you can comment on or make changes to this bug.