Bug 674493 - [abrt] anki-1.2.5-1.fc13: subprocess.py:1126:_execute_child:OSError: [Errno 2] No such file or directory
Summary: [abrt] anki-1.2.5-1.fc13: subprocess.py:1126:_execute_child:OSError: [Errno 2...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anki
Version: 13
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christian Krause
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b60b5002
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-02 06:40 UTC by nomnex
Modified: 2011-03-11 20:57 UTC (History)
1 user (show)

Fixed In Version: anki-1.2.7-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-07 01:32:15 UTC


Attachments (Terms of Use)
File: backtrace (1.65 KB, text/plain)
2011-02-02 06:40 UTC, nomnex
no flags Details

Description nomnex 2011-02-02 06:40:42 UTC
abrt version: 1.1.14
architecture: i686
cmdline: /usr/bin/python /usr/bin/anki
component: anki
executable: /usr/bin/anki
kernel: 2.6.34.7-66.fc13.i686
package: anki-1.2.5-1.fc13
reason: subprocess.py:1126:_execute_child:OSError: [Errno 2] No such file or directory
release: Fedora release 13 (Goddard)
time: 1296628122
uid: 500

backtrace
-----
subprocess.py:1126:_execute_child:OSError: [Errno 2] No such file or directory

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/ankiqt/ui/facteditor.py", line 986, in onRecSound
    file = getAudio(self.parent)
  File "/usr/lib/python2.6/site-packages/ankiqt/ui/sound.py", line 37, in getAudio
    r.postprocess(encode)
  File "/usr/lib/python2.6/site-packages/anki/sound.py", line 276, in postprocess
    ret = retryWait(subprocess.Popen(c, startupinfo=si))
  File "/usr/lib/python2.6/subprocess.py", line 621, in __init__
    errread, errwrite)
  File "/usr/lib/python2.6/subprocess.py", line 1126, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory

Local variables in innermost frame:
errread: None
c2pread: None
gc_was_enabled: True
errwrite: None
shell: False
errpipe_write: 22
executable: 'sox'
close_fds: False
self: <subprocess.Popen object at 0xa71cdac>
env: None
cwd: None
child_exception: OSError(2, 'No such file or directory')
args: ['sox', 'rec.wav', 'rec2.wav']
fd: None
c2pwrite: None
data: 'cexceptions\nOSError\np0\n(I2\nS\'No such file or directory\'\np1\ntp2\nRp3\n(dp4\nS\'child_traceback\'\np5\nS\'Traceback (most recent call last):\\n  File "/usr/lib/python2.6/subprocess.py", line 1083, in _execute_child\\n    os.execvp(executable, args)\\n  File "/usr/lib/python2.6/os.py", line 344, in execvp\\n    _execvpe(file, args)\\n  File "/usr/lib/python2.6/os.py", line 380, in _execvpe\\n    func(fullname, *argrest)\\nOSError: [Errno 2] No such file or directory\\n\'\np6\nsb.'
creationflags: 0
errpipe_read: 21
preexec_fn: None
p2cread: None
startupinfo: None
p2cwrite: None
universal_newlines: False

comment
-----
I am testing Anki 1.2.5 (from bohdi updates).  I am not sure if I can report bugs for testing version here ? (I have made a comment on the bohdi page).

Anki crashes when using "Record audio (F5)" while editing a card.

How to reproduce
-----
1. Open an Anki deck
2. Open the browser (Ctrl+F)
3. Select a card and push the icon > Record audio (F5) located on the top right of the editing pane.

Comment 1 nomnex 2011-02-02 06:40:44 UTC
Created attachment 476523 [details]
File: backtrace

Comment 2 Christian Krause 2011-02-27 19:28:24 UTC
The issue is caused by the missing "sox" binary. Just install the "sox" package, e.g. with "yum install sox". In a later update of anki I will add "sox" to the list of required pre-requisites.

Comment 3 Fedora Update System 2011-03-02 23:33:05 UTC
Package anki-1.2.7-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anki-1.2.7-1.fc15'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/anki-1.2.7-1.fc15
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2011-03-02 23:33:19 UTC
Package anki-1.2.7-1.fc13:
* should fix your issue,
* was pushed to the Fedora 13 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anki-1.2.7-1.fc13'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/anki-1.2.7-1.fc13
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2011-03-02 23:33:23 UTC
Package anki-1.2.7-1.fc14:
* should fix your issue,
* was pushed to the Fedora 14 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anki-1.2.7-1.fc14'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/anki-1.2.7-1.fc14
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2011-03-03 03:38:47 UTC
anki-1.2.7-1.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anki'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/anki-1.2.7-1.fc15

Comment 7 nomnex 2011-03-07 01:27:50 UTC
(In reply to comment #2)
> The issue is caused by the missing "sox" binary. Just install the "sox"
> package, e.g. with "yum install sox". In a later update of anki I will add
> "sox" to the list of required pre-requisites.

Thank you Christian. I have updated the latest Anki 1.2.7 testing, including sox in the package.

Comment 8 Fedora Update System 2011-03-07 01:32:06 UTC
anki-1.2.7-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-03-11 20:52:02 UTC
anki-1.2.7-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-03-11 20:57:05 UTC
anki-1.2.7-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.