Bug 674597 - Rebuild for glibc-2.13-1.fc14
Rebuild for glibc-2.13-1.fc14
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gdb-heap (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dave Malcolm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-02 10:33 EST by Nicolas Chauvet (kwizart)
Modified: 2011-07-30 23:35 EDT (History)
4 users (show)

See Also:
Fixed In Version: gdb-heap-0.5-3.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-30 23:35:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Chauvet (kwizart) 2011-02-02 10:33:51 EST
Description of problem: yum update breaks because of a either spurious or hardcoded dependency on glibc


Version-Release number of selected component (if applicable):
gdb-heap-0.5-1.fc14

How reproducible:
always

Steps to Reproduce:
1. yum install gdb-heat 
2. yum update
3. yum will then breaks
  
Actual results:
Erreur : Package: gdb-heap-0.5-1.fc14.x86_64 (fedora)
             Requires: glibc(x86-64) = 2.12.90
             Installé: glibc-2.13-1.x86_64 (@updates-testing)
                 glibc(x86-64) = 2.13-1
             Available: glibc-2.12.90-17.x86_64 (fedora)
                 glibc(x86-64) = 2.12.90-17
             Available: glibc-2.12.90-21.x86_64 (updates)
                 glibc(x86-64) = 2.12.90-21
 Vous pouvez essayer d'utiliser --skip-broken pour contourner le problème
# rpm -q glibc
glibc-2.13-1.x86_64
glibc-2.13-1.i686

Expected results:
yum update should be kept silent from dependency breakage.

Additional info:
glibc has been approved for critpath update. Unless already in buildroot, a buildroot override have to be requested at rel-eng
Comment 1 jurek.bajor 2011-02-09 08:04:00 EST
We have the same problem on F14 32-bit.

# yum distro-sync
Loaded plugins: fastestmirror, presto, priorities
0 packages excluded due to repository priority protections
Setting up Distribution Synchronization Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: glibc(x86-32) = 2.12.90 for package:
gdb-heap-0.5-1.fc14.i686
---> Package glibc.i686 0:2.13-1 set to be updated
---> Package glibc-common.i686 0:2.13-1 set to be updated
---> Package glibc-devel.i686 0:2.13-1 set to be updated
---> Package glibc-headers.i686 0:2.13-1 set to be updated
---> Package nscd.i686 0:2.13-1 set to be updated
--> Finished Dependency Resolution
Error: Package: gdb-heap-0.5-1.fc14.i686 (@fedora)
           Requires: glibc(x86-32) = 2.12.90
           Removing: glibc-2.12.90-21.i686 (@updates)
               glibc(x86-32) = 2.12.90-21
           Updated By: glibc-2.13-1.i686 (updates)
               glibc(x86-32) = 2.13-1
           Available: glibc-2.12.90-17.i686 (fedora)
               glibc(x86-32) = 2.12.90-17
 You could try using --skip-broken to work around the problem

# yum list "*glibc*"
Installed Packages
glibc.i686                                 2.12.90-21                   @updates
glibc-common.i686                          2.12.90-21                   @updates
glibc-devel.i686                           2.12.90-21                   @updates
glibc-headers.i686                         2.12.90-21                   @updates
Available Packages
arm-gp2x-linux-glibc.noarch                2.3.6-8.fc14                 fedora
glibc.i686                                 2.13-1                       updates
glibc-common.i686                          2.13-1                       updates
glibc-devel.i686                           2.13-1                       updates
glibc-headers.i686                         2.13-1                       updates
glibc-static.i686                          2.13-1                       updates
glibc-utils.i686                           2.13-1                       updates
Comment 2 Daniel 2011-02-14 17:18:10 EST
not possible to install gdb-heap on recent fc14 for same reason:

# yum install gdb-heap
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package gdb-heap.x86_64 0:0.5-1.fc14 set to be installed
--> Processing Dependency: glibc(x86-64) = 2.12.90 for package: gdb-heap-0.5-1.fc14.x86_64
--> Processing Dependency: python-ply for package: gdb-heap-0.5-1.fc14.x86_64
--> Running transaction check
---> Package gdb-heap.x86_64 0:0.5-1.fc14 set to be installed
--> Processing Dependency: glibc(x86-64) = 2.12.90 for package: gdb-heap-0.5-1.fc14.x86_64
---> Package python-ply.noarch 0:3.3-3.fc14 set to be installed
--> Finished Dependency Resolution
Error: Package: gdb-heap-0.5-1.fc14.x86_64 (fedora)
           Requires: glibc(x86-64) = 2.12.90
           Installed: glibc-2.13-1.x86_64 (@updates)
               glibc(x86-64) = 2.13-1
           Available: glibc-2.12.90-17.x86_64 (fedora)
               glibc(x86-64) = 2.12.90-17
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 3 Olivier Crête 2011-06-08 15:09:35 EDT
Damn, same thing for F15.. Isn't there a way to make sure a new gdb-heap package is pushed with glibc updates ?
Comment 4 Fedora Update System 2011-07-18 16:29:46 EDT
gdb-heap-0.5-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gdb-heap-0.5-3.fc14
Comment 5 Fedora Update System 2011-07-22 15:32:37 EDT
Package gdb-heap-0.5-3.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gdb-heap-0.5-3.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/gdb-heap-0.5-3.fc14
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2011-07-30 23:35:11 EDT
gdb-heap-0.5-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.