Bug 674633 - Cannot log in as non-root user, immediately logged out
Cannot log in as non-root user, immediately logged out
Status: CLOSED DUPLICATE of bug 674443
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan F. Chadima
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-02 13:27 EST by Richard W.M. Jones
Modified: 2011-02-02 15:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-02 15:49:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2011-02-02 13:27:16 EST
Description of problem:

ssh-ing as non-root to a virtual machine gives:

$ ssh 192.168.122.76
rjones@192.168.122.76's password: 
Connection to 192.168.122.76 closed by remote host.
Connection to 192.168.122.76 closed.

(The password there was correct).

However it works if I log in as root.

On the server side there's not much in /var/log/secure.  For
unsuccessful non-root login it says:

Feb  2 18:24:00 rawhide sshd[1474]: Accepted password for rjones from 192.168.122.1 port 48653 ssh2
Feb  2 18:24:00 rawhide sshd[1475]: fatal: mm_request_receive: read: Connection reset by peer
Feb  2 18:24:00 rawhide sshd[1474]: pam_unix(sshd:session): session opened for user rjones by (uid=0)
Feb  2 18:24:00 rawhide sshd[1474]: pam_unix(sshd:session): session closed for user rjones
Feb  2 18:24:00 rawhide sshd[1474]: syslogin_perform_logout: logout() returned an error

For successful root login it says:

Feb  2 18:19:31 rawhide sshd[1385]: Accepted password for root from 192.168.122.1 port 56091 ssh2
Feb  2 18:19:31 rawhide sshd[1386]: fatal: mm_request_receive: read: Connection reset by peer
Feb  2 18:19:31 rawhide sshd[1385]: pam_unix(sshd:session): session opened for user root by (uid=0)

Version-Release number of selected component (if applicable):

Server: openssh-server-5.6p1-26.fc15.x86_64
Client: openssh-clients-5.5p1-24.fc14.2.x86_64

How reproducible:

100%

Steps to Reproduce:
1. ssh to Rawhide virtual machine as non-root.
2.
3.
  
Actual results:

Accepts password, then immediately closes the connection.

Expected results:

Logs me in.

Additional info:
Comment 1 Richard W.M. Jones 2011-02-02 13:28:08 EST
There's nothing much in /var/log/messages.  Any other
log files I should be looking at?

SELinux is Permissive.

The VM is using systemd.
Comment 2 Richard W.M. Jones 2011-02-02 13:29:16 EST
I can log in as non-root at the VM console (ie. using
virt-viewer).  And I was able to log in to this machine
before just fine, before updating all the packages to
the latest Rawhide and rebooting it.  After that big
update and reboot, the trouble started.
Comment 3 Tomas Mraz 2011-02-02 15:49:28 EST

*** This bug has been marked as a duplicate of bug 674443 ***

Note You need to log in before you can comment on or make changes to this bug.