This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 674692 - Review Request: python-pyramid - The Pyramid web application framework, a Pylons project
Review Request: python-pyramid - The Pyramid web application framework, a Pyl...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On: 674666 674667 674671 674674 674676 674682
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-02 17:41 EST by Luke Macken
Modified: 2016-09-19 22:41 EDT (History)
6 users (show)

See Also:
Fixed In Version: python-pyramid-1.0-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-02 21:56:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
tla: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Luke Macken 2011-02-02 17:41:41 EST
Spec URL: http://lmacken.fedorapeople.org/rpms/python-pyramid.spec
SRPM URL: http://lmacken.fedorapeople.org/rpms/python-pyramid-1.0-1.fc13.src.rpm
Description:
Pyramid is a small, fast, down-to-earth, open source Python web development
framework. It makes real-world web application development and deployment more
fun, more predictable, and more productive.
Comment 1 Tim Lauridsen 2011-02-17 01:42:49 EST
I will review this bug
Comment 2 Tim Lauridsen 2011-02-17 01:51:06 EST
No spec file :)

I complete this when the deps are reviewed and pushed into the mirrors
Comment 3 Luke Macken 2011-02-17 02:06:29 EST
Oops, sorry about that.  The spec should be there now :)
Comment 4 Tim Lauridsen 2011-02-23 04:54:43 EST
Source0 should be

http://pypi.python.org/packages/source/p/pyramid/%{modname}-%{version}.tar.gz
Comment 5 Tim Lauridsen 2011-02-23 04:55:26 EST
%define modname pyramid

should be

%global modname pyramid
Comment 6 Tim Lauridsen 2011-02-23 05:40:33 EST
the is a lot of test stuff under 

/usr/lib/python2.7/site-packages/pyramid/tests

Would it not be better to put this under /usr/share/pyramid/tests

It looks like usage examples to me.

there is all kind of files .po, .mo, .html etc.

or maybe it should go into -doc sub package.

If you what to use this framework on a server, you dont want all that test/usage examples to be installed.
Comment 7 Luke Macken 2011-02-23 13:50:06 EST
Fixed source and %global, and removed tests completely after running them (as we do with many other python packages)

Spec URL: http://lmacken.fedorapeople.org/rpms/python-pyramid.spec
SRPM URL: http://lmacken.fedorapeople.org/rpms/python-pyramid-1.0-1.fc13.src.rpm
Comment 8 Tim Lauridsen 2011-02-24 04:42:29 EST
Package Review
==============

Key:
- = N/A
x = Check
! = Problem
? = Not evaluated

[x] : MUST - Package successfully compiles and builds into binary rpms on at least one supported architecture.
[x] : MUST - Buildroot is correct (EPEL5 & Fedora < 10)
        %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
[x] : MUST - Package has a %clean section, which contains rm -rf %{buildroot} (or $RPM_BUILD_ROOT).(EPEL6 & Fedora < 13)
[x] : MUST - Each %files section contains %defattr
[-] : MUST - Header files in -devel subpackage, if present.
[x] : MUST - Spec file lacks Packager, Vendor, PreReq tags.
[x] : MUST - Package run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) and the beginning of %install.
[-] : MUST - ldconfig called in %post and %postun if required.
[x] : MUST - Package does not contain any libtool archives (.la)
[x] : MUST - Package use %makeinstall only when make install DESTDIR=... doesn't work.
[x] : MUST - Package is named according to the Package Naming Guidelines.
[-] : MUST - Package requires pkgconfig, if .pc files are present. (EPEL5)
[!] : MUST - Rpmlint output is silent.
        
        rpmlint python-pyramid-1.0-1.fc16.noarch.rpm
        ================================================================================
        python-pyramid.noarch: E: script-without-shebang /usr/lib/python2.7/site-packages/pyramid/paster_templates/alchemy/+package+/models.py
        python-pyramid.noarch: E: script-without-shebang /usr/lib/python2.7/site-packages/pyramid/paster_templates/alchemy/+package+/__init__.py_tmpl
        python-pyramid.noarch: W: no-manual-page-for-binary bfg2pyramid
        1 packages and 0 specfiles checked; 2 errors, 1 warnings.
        ================================================================================
        
        rpmlint python-pyramid-1.0-1.fc16.src.rpm
        ================================================================================
        1 packages and 0 specfiles checked; 0 errors, 0 warnings.
        ================================================================================
	
No deal breakers        

[-] : MUST - Development .so files in -devel subpackage, if present.
[x] : MUST - Sources used to build the package matches the upstream source, as provided in the spec URL.
        MD5SUM this package     : 811ac86625e39083f24f2b6d400a5d39
        MD5SUM upstream package : 811ac86625e39083f24f2b6d400a5d39
[x] : MUST - Spec file name must match the spec package %{name}, in the format %{name}.spec.
[-] : MUST - Static libraries in -static subpackage, if present.
[x] : MUST - Spec file is legible and written in American English.
[x] : MUST - Spec uses macros instead of hard-coded directory names.
[x] : MUST - Package consistently uses macros.
[x] : MUST - Macros in Summary, %description expandable at SRPM build time.
[x] : MUST - Requires correct, justified where necessary.
[!] : MUST - All build dependencies are listed in BuildRequires, except for any that are listed in the exceptions section
 of Packaging Guidelines.
	BuildRequires: python2-devel is missing 
	http://fedoraproject.org/wiki/Packaging:Python#BuildRequires
[-] : MUST - The spec file handles locales properly.
[x] : MUST - Changelog in prescribed format.
[x] : MUST - License field in the package spec file matches the actual license.
[x] : MUST - If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package is included in %doc.
[-] : MUST - License file installed when any subpackage combination is installed.
[x] : MUST - Package is licensed with an open-source compatible license and meets other legal requirements as defined in the legal section of Packaging Guidelines.
[x] : MUST - Sources contain only permissible code or content.
[x] : MUST - Compiler flags are appropriate.
[x] : MUST - %build honors applicable compiler flags or justifies otherwise.
[x] : MUST - Package must own all directories that it creates.
[x] : MUST - Package does not own files or directories owned by other packages.
[x] : MUST - Package requires other packages for directories it uses.
[x] : MUST - Package does not contain duplicates in %files.
[x] : MUST - Permissions on files are set properly.
[-] : MUST - No %config files under /usr.
[-] : MUST - %config files are marked noreplace or the reason is justified.
[-] : MUST - Package contains a properly installed %{name}.desktop using desktop-file-install file if it is a GUI application.
[x] : MUST - Package contains code, or permissable content.
[x] : MUST - Package contains a SysV-style init script if in need of one.
[x] : MUST - File names are valid UTF-8.
[x] : MUST - Large documentation files are in a -doc subpackage, if required.
[x] : MUST - Package uses nothing in %doc for runtime.
[x] : MUST - Package contains no bundled libraries.
[x] : MUST - Package contains no static executables.
[-] : MUST - Fully versioned dependency in subpackages, if present.
[x] : MUST - Useful -debuginfo package or justification otherwise.
[x] : MUST - Rpath absent or only used for internal libs.
[x] : MUST - Package does not genrate any conflict.
[x] : MUST - Package does not contains kernel modules.
[x] : MUST - Package is not relocatable.
[x] : MUST - Package is not known to require ExcludeArch.
[x] : MUST - Package installs properly.
[x] : MUST - Package obeys FHS, except libexecdir and /usr/target.
[x] : MUST - Package meets the Packaging Guidelines.
[x] : SHOULD - Reviewer should test that the package builds in mock.
[x] : SHOULD - Spec use %global instead of %define.
[x] : SHOULD - Dist tag is present.
[-] : SHOULD - Uses parallel make.
[-] : SHOULD - The placement of pkgconfig(.pc) files are correct.
[x] : SHOULD - SourceX / PatchY prefixed with %{name}.
[x] : SHOULD - SourceX is a working URL.
[?] : SHOULD - Package functions as described.
[x] : SHOULD - Latest version is packaged.
[x] : SHOULD - Package does not include license text files separate from upstream.
[-] : SHOULD - If the source package does not include license text(s) as a separate file from upstream, the packager SHOULD query upstream to include it.
[!] : SHOULD - Description and summary sections in the package spec file contains translations for supported Non-English languages, if available.
[x] : SHOULD - Final provides and requires are sane (rpm -q --provides and rpm -q --requires).
[x] : SHOULD - %check is present and all tests pass.
[x] : SHOULD - Usually, subpackages other than devel should require the base package using a fully versioned dependency.
[?] : SHOULD - Package should compile and build into binary rpms on all supported architectures.
[x] : SHOULD - Scriptlets must be sane, if used.
[x] : SHOULD - No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x] : SHOULD - Packages should try to preserve timestamps of original installed files.
[-] : SHOULD - File based requires are sane.
[!] : SHOULD - Man pages included for all executables.
[!] : SHOULD - Patches link to upstream bugs/comments/lists or are otherwise justified.
	OK, but an comment about the bug, would be nice.
	http://fedoraproject.org/wiki/PackagingGuidelines#All_patches_should_have_an_upstream_bug_link_or_comment

Issues:
[!] : MUST - All build dependencies are listed in BuildRequires, except for any that are listed in the exceptions section
 of Packaging Guidelines.
	BuildRequires: python2-devel is missing 
	http://fedoraproject.org/wiki/Packaging:Python#BuildRequires
[!] : SHOULD - Patches link to upstream bugs/comments/lists or are otherwise justified.
	OK, but an comment about the bug, would be nice.
	http://fedoraproject.org/wiki/PackagingGuidelines#All_patches_should_have_an_upstream_bug_link_or_comment
Comment 9 Luke Macken 2011-02-24 12:53:22 EST
(In reply to comment #8)
> Package Review
> ==============
> [!] : MUST - All build dependencies are listed in BuildRequires, except for any
> that are listed in the exceptions section
>  of Packaging Guidelines.
>  BuildRequires: python2-devel is missing 
>  http://fedoraproject.org/wiki/Packaging:Python#BuildRequires

Added.

> [?] : SHOULD - Package functions as described.

You can test that the package works as expected by doing the following:

    $ paster create -t pyramid_alchemy testpyramid
    $ cd testpyramid
    $ paster serve development.ini

Then fire up your web browser and make sure the default page loads.

> [!] : SHOULD - Patches link to upstream bugs/comments/lists or are otherwise
> justified.
>  OK, but an comment about the bug, would be nice.
> http://fedoraproject.org/wiki/PackagingGuidelines#All_patches_should_have_an_upstream_bug_link_or_comment

Comment added.

Spec and SRPM updated, with the same URL as above.
Comment 10 Tim Lauridsen 2011-02-24 13:18:37 EST
Looks good

APPROVED
Comment 11 Luke Macken 2011-02-24 13:22:24 EST
New Package SCM Request
=======================
Package Name: python-pyramid
Short Description: The Pyramid web application framework, a Pylons project
Owners: lmacken
Branches: f14 f15 el6 el5
Comment 12 Jason Tibbitts 2011-02-24 13:27:55 EST
Git done (by process-git-requests).
Comment 13 Fedora Update System 2011-02-24 15:39:28 EST
python-pyramid-1.0-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/python-pyramid-1.0-1.fc15
Comment 14 Fedora Update System 2011-02-25 18:19:35 EST
python-pyramid-1.0-1.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-pyramid'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/python-pyramid-1.0-1.fc15
Comment 15 Fedora Update System 2011-03-02 21:56:42 EST
python-pyramid-1.0-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Ralph Bean 2014-10-13 12:46:15 EDT
Package Change Request
======================
Package Name: python-pyramid
New Branches: epel7
Owners: ralph
Comment 17 Kevin Fenzi 2014-10-13 19:03:12 EDT
Git done (by process-git-requests).

Note You need to log in before you can comment on or make changes to this bug.