Bug 67475 - vgetty will not answer Sprint or Voicestream calls
vgetty will not answer Sprint or Voicestream calls
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: mgetty (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-25 18:17 EDT by Bruce Garlock
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-01 17:18:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce Garlock 2002-06-25 18:17:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
I am having a rough time trying to figure this one out.  For some
reason, vgetty does not pick up and present the greeting message when a
Sprint or Voice Stream customer calls into the computer.  It answers all
other phone calls fine.  Here is what the log looks like, when it does
not pick up those calls:

06/25 16:33:18 yE1  waiting...
06/25 17:13:29 yE1  wfr: waiting for ``RING''
06/25 17:13:29 yE1  wfr: waiting for ``RING''
06/25 17:13:33 yE1  wfr: found action string: ``CONNECT''
06/25 17:13:34 yE1  WARNING: starting login while DCD is low!
06/25 17:13:34 ##### data dev=ttyE1, pid=22557, caller='none', conn='',
name='', cmd=
'/bin/login', user='1496'

Basically, you can hear the modem (Zyxel 1496, ROM 6.19) ring twice, but
the phone keeps ringing.  I'm guessing the Zyxel picks up somehow, and
according to the log, thinks it's a data call?  

I'm guessing the Sprint and Voicestream customers phone must send some
sort of signal in their ring, defeating vgetty some how. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Sprint or Voicestream Customer calls into machine running vgetty
2.
3.
	

Actual Results:  Voice greeting message is not played.

Expected Results:  Voice greeting message should be played, like it does all
other calls.

Additional info:

Verizon wireless works fine.
Comment 1 Jason Vas Dias 2005-08-01 17:18:04 EDT
Apologies for the very long delay in processing this bug - it got lost somehow
and I have only recently taken over maintenance of the mgetty package.
I have not been able to reproduce this problem with mgetty-voice-1.1.33 and
vgetty with a V253 compliant modem (Hayes Accura), receiving voice calls from
a GSM mobile phone . 
If you can still reproduce this problem with mgetty-1.1.33, please re-open 
this bug - thank you .
 

Note You need to log in before you can comment on or make changes to this bug.