Bug 674799 - Isn't dragged in for upgrades
Isn't dragged in for upgrades
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-themes-standard (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cosimo Cecchi
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F15-accepted/F15FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2011-02-03 07:11 EST by Bastien Nocera
Modified: 2013-04-30 18:55 EDT (History)
5 users (show)

See Also:
Fixed In Version: gnome-desktop3-3.0.0-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-26 12:23:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2011-02-03 07:11:28 EST
The theme and background in gnome-themes-standard are the default for gnome-shell, but they're not getting dragged in by anything for upgrade.

An F14 installation updated to rawhide will not have gnome-themes-standard installed by default.
Comment 1 Richard Hughes 2011-02-03 09:12:06 EST
Can we just roll gnome-themes-standard into gnome-themes itself?
Comment 2 Bastien Nocera 2011-02-04 15:48:49 EST
(In reply to comment #1)
> Can we just roll gnome-themes-standard into gnome-themes itself?

They're separate packages, and upstream sources.
Comment 3 Adam Williamson 2011-04-15 14:54:52 EDT
Discussed at the 2011-04-15 blocker review meeting. Impact of this bug seems unclear.

The relevant criteria:

Alpha - "# The default Fedora artwork must either refer to the current Fedora release under development (Fedora 15), or reference an interim release milestone (e.g. Alpha or Beta). If a release version number is used, it must match the current Fedora release under development. This includes artwork used in the installer, firstboot, graphical boot, graphical login and desktop background. "

Final - "# The proposed final Fedora artwork must be included and enabled by default for the installer, graphical boot, firstboot, graphical login and desktop background. All Fedora artwork must be consistent with the proposed final theme, and if any artwork contains a graphical version number, the version number used must match the Fedora release number. Generic release artwork (e.g. Alpha, Beta, Development) must not be used for the final release "

Beta - "# The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation (from any official install medium) of the previous stable Fedora release, either via preupgrade or by booting to the installer manually. The upgraded system must meet all release criteria "

I'd probably interpret that to mean that upgrades from F14 to F15 should have either the F15 artwork or the F15/GNOME 3 artwork. I don't think the criteria have anything to say on whether the *upstream* GNOME 3 artwork should be available.

Can you guys provide more info on the impact of this bug, keeping the above in mind, so we can properly evaluate its status next week? Thanks.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Fedora Update System 2011-04-15 16:28:10 EDT
gnome-desktop3-3.0.0-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gnome-desktop3-3.0.0-2.fc15
Comment 5 Fedora Update System 2011-04-15 20:12:02 EDT
Package gnome-desktop3-3.0.0-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-desktop3-3.0.0-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/gnome-desktop3-3.0.0-2.fc15
then log in and leave karma (feedback).
Comment 6 Tim Flink 2011-04-21 14:05:48 EDT
Discussed at the 2011-04-21 blocker bug review meeting.

Since this does not affect the default fedora artwork (only the upstream gnome artwork), it does not directly hit any release criteria and was rejected as a blocker.

Accepted as NTH since it should be installed and may contain default GTK icons.
Comment 7 Fedora Update System 2011-04-26 12:23:31 EDT
gnome-desktop3-3.0.0-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.