Bug 674916 - /sbin/service hangs in some cases
Summary: /sbin/service hangs in some cases
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-03 18:13 UTC by Rob Crittenden
Modified: 2011-02-09 04:34 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-09 00:38:43 UTC
Type: ---


Attachments (Terms of Use)
python script that demonstrates the hang (1.00 KB, text/plain)
2011-02-03 18:14 UTC, Rob Crittenden
no flags Details

Description Rob Crittenden 2011-02-03 18:13:40 UTC
Description of problem:

This was discovered when trying to install the freeipa package. During installation a number of services are configured and need to be restarted. The installer was hanging whenever a service was restarted.

While trying to diagnose this I discovered that strace -f will also demonstrate the hang.

Version-Release number of selected component (if applicable):

systemd-17-1.fc15.x86_64

Steps to Reproduce:

1. yum install ntpd strace
2. strace -f /sbin/service restart ntpd

Comment 1 Rob Crittenden 2011-02-03 18:14:41 UTC
Created attachment 476839 [details]
python script that demonstrates the hang

If you change the value of capture_output in the script to False then the script will exit gracefully.

Comment 2 Lennart Poettering 2011-02-09 00:03:49 UTC
Fixed upstream:

http://cgit.freedesktop.org/systemd/commit/?id=7f6d613516020bf390d8de25bbbb2551ea8dade0

Note that the strace -f issue is unrelated to the python popen() issue. The strace -f issue happens because strace interferes with the process tree and PR_SETDEATHSIG hence loses its meaning. Not sure we really need to fix that given that this only happens when strace as debugging tool is used.

The popen() issue is fixed.

Comment 3 Lennart Poettering 2011-02-09 00:38:43 UTC
Built a new package now in koji:

http://koji.fedoraproject.org/koji/taskinfo?taskID=2798040

Please test and reopen in case this desn't fix the issue.

Comment 4 Rob Crittenden 2011-02-09 04:34:32 UTC
Using this build I was able to do a minimal FreeIPA server installation. Still need to do more testing but initial results are very positive.


Note You need to log in before you can comment on or make changes to this bug.