Bug 675048 - no network interfaces found on boot after HTTP installation
Summary: no network interfaces found on boot after HTTP installation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: biosdevname
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Matt Domsch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedNTH
Depends On:
Blocks: F15Alpha-accepted, F15AlphaFreezeExcept
TreeView+ depends on / blocked
 
Reported: 2011-02-04 02:44 UTC by Felix Miata
Modified: 2011-02-28 15:23 UTC (History)
10 users (show)

Fixed In Version: biosdevname-0.3.7-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-19 03:50:38 UTC


Attachments (Terms of Use)
lspci output and tail -n1000 /var/log/messages (94.23 KB, text/plain)
2011-02-04 17:13 UTC, Felix Miata
no flags Details
/var/log/anaconda/anaconda.ifcfg.log (6.51 KB, text/plain)
2011-02-04 17:19 UTC, Felix Miata
no flags Details

Description Felix Miata 2011-02-04 02:44:59 UTC
Description of problem:
no eth0, eth1 or pci1#1, thus no networking

How reproducible:
Two installs in three days on same system with same result.

Steps to Reproduce:
1.start HTTP installation from Grub using initrd.img & vmlinuz from http://alt.fedoraproject.org/pub/alt/stage/15-Alpha.TC1/Fedora/i386/os/isolinux/
2.select and proceed with minimal installation type
3.boot newly installed system

Actual results:
yum can't install anything
no networking
ifconfig can find no network interfaces

Expected results:
network works

Additional info:
lsmod shows as loaded required e100 module

Comment 1 Felix Miata 2011-02-04 17:13:14 UTC
Created attachment 477069 [details]
lspci output and tail -n1000 /var/log/messages

I've since installed several more times, always with similar results - very long boot times, lots of trace messages, and anything network related failing. On the last attempt I eventually got to a login, logged in as root, and did 'ifconfig -a'. The result of that doesn't seem ever to have occurred. Something must be in an endless loop.

Comment 2 Felix Miata 2011-02-04 17:19:25 UTC
Created attachment 477071 [details]
/var/log/anaconda/anaconda.ifcfg.log

Comment 3 Robert Scheck 2011-02-07 23:34:02 UTC
I'm not sure, why the reporter selected "ethtool" as component, because our
ethtool shouldn't be responsible for the described result. Reassigning to the
anaconda team, because I feel this is more anaconda than ethtool related...

Comment 4 Brian Lane 2011-02-08 00:54:01 UTC
biosdevname needs to be updated to not use # in the device name.

Comment 5 Fedora Update System 2011-02-17 16:23:22 UTC
biosdevname-0.3.7-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/biosdevname-0.3.7-1.fc15

Comment 6 Felix Miata 2011-02-17 20:07:17 UTC
That URL is refusing me access.

Comment 7 Adam Williamson 2011-02-17 20:49:08 UTC
this definitely looks like a +1 nth to me. If it affects enough people it's arguably a blocker, as it breaks "The installed system must be able to download and install updates with yum and PackageKit" - can't install updates with no networking.

Comment 8 Fedora Update System 2011-02-17 22:24:56 UTC
biosdevname-0.3.7-1.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update biosdevname'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/biosdevname-0.3.7-1.fc15

Comment 9 James Laska 2011-02-18 20:07:22 UTC
From the 2011-02-18 Alpha blocker review meeting
(http://meetbot.fedoraproject.org/fedora-bugzappers/2011-02-18/f15-alpha-bug-review.2011-02-18-17.00.html)

AGREED: 675048 - AcceptedNTH, updated koji build available

Comment 10 Fedora Update System 2011-02-19 03:50:11 UTC
biosdevname-0.3.7-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Felix Miata 2011-02-25 16:36:06 UTC
eth0 now found in 15alphaRC1, except it's been immemorably renamed to pci11p1 :-(

Comment 12 James Laska 2011-02-28 14:53:21 UTC
(In reply to comment #11)
> eth0 now found in 15alphaRC1, except it's been immemorably renamed to pci11p1
> :-(

See https://fedoraproject.org/wiki/Features/ConsistentNetworkDeviceNaming

Comment 13 Felix Miata 2011-02-28 15:16:26 UTC
Yi yi yi yi yi yi yi, so complicated! So now one need find the back of the machine to see whether onboard or slot, and if slot guess which slot the NIC is in to predict what the name should be, and if onboard has more than one, guess which is/are which. :-( The new names should alias to legacy names.

Comment 14 James Laska 2011-02-28 15:23:05 UTC
(In reply to comment #13)
> Yi yi yi yi yi yi yi, so complicated! So now one need find the back of the
> machine to see whether onboard or slot, and if slot guess which slot the NIC is
> in to predict what the name should be, and if onboard has more than one, guess
> which is/are which. :-( The new names should alias to legacy names.

See the link I previously noted for ways to get involved with the feature, and to voice concerns.  This bug report isn't the proper place for feedback on the feature to be heard.

Comment 15 Harald Hoyer 2011-02-28 15:23:16 UTC
(In reply to comment #13)
> The new names should alias to legacy names.

There is no such thing as a network "alias/symlink"!


Note You need to log in before you can comment on or make changes to this bug.