Bug 675079 - Specifying bonding arp_ip_target options in modprobe.conf can prevent restarting network
Summary: Specifying bonding arp_ip_target options in modprobe.conf can prevent restart...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: initscripts Maintenance Team
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: GSS_6_2_PROPOSED 697582
TreeView+ depends on / blocked
 
Reported: 2011-02-04 08:48 UTC by Takuma Umeya
Modified: 2018-11-14 14:49 UTC (History)
5 users (show)

Fixed In Version: initscripts-9.03.24-1.el6
Doc Type: Bug Fix
Doc Text:
Cause bonding set with a /etc/modprobe.d/bonding.conf file Consequence What happens when the bug presents. bond0 will never come up after service network restart Result the arp_ip_target is restored even when specified in modprobe.conf
Clone Of:
Environment:
Last Closed: 2011-12-06 18:09:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1528 normal SHIPPED_LIVE initscripts bug fix and enhancement update 2011-12-06 01:02:05 UTC

Description Takuma Umeya 2011-02-04 08:48:48 UTC
Description of problem:
The fix for bug #483711 cleans up /sys/class/net/bondX/bonding/arp_ip_target in
ifdown.
When using /etc/modprobe.conf to set the bonding options (and not BONDING_OPTS
in /etc/sysconfig/network-scripts/ifcfg-bond<x>, ie old-style config), then the
interface will not come up after a network restart because the arp_ip_target is
not restored.
BZ604669 takes care of the same issue on RHEL5. 

Version-Release number of selected component (if applicable):
initscripts-9.03.17-1.el6

How reproducible:
Always

Steps to Reproduce:
1. set bonding with a /etc/modprobe.d/bonding.conf file.
alias bond0 bonding
options bond0 mode=1 arp_interval=1000 arp_ip_target=192.168.0.1

2. start network service.
# service network start

3. restart network service.
# service network restart
  
Actual results:
bond0 will never come up because the  arp_ip_target is cleared in ifdown

Expected results:
the arp_ip_target should be restored even when specified in modprobe.conf

Additional info:

Comment 2 Bill Nottingham 2011-02-04 15:47:06 UTC
With repsect to the specific patch, see https://bugzilla.redhat.com/show_bug.cgi?id=604669#c3

Comment 4 Bill Nottingham 2011-04-12 13:02:32 UTC
Upstream version at 5749d2e9d5795fdaf65b97befd64cf90103d423d.

Comment 5 Bill Nottingham 2011-04-12 13:47:15 UTC
Need b24d6b8 as well.

Comment 9 Petr Lautrbach 2011-10-17 11:15:06 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
    bonding set with a /etc/modprobe.d/bonding.conf file

Consequence
    What happens when the bug presents.
    bond0 will never come up after service network restart

Result
    the arp_ip_target is restored even when specified in modprobe.conf

Comment 13 errata-xmlrpc 2011-12-06 18:09:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1528.html


Note You need to log in before you can comment on or make changes to this bug.