Bug 675193 - Confusing text on the ChannelCreateFiles.do page
Confusing text on the ChannelCreateFiles.do page
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
540
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Tomas Lestach
Pavel Studeník
: EasyFix
Depends On:
Blocks: sat560-blockers
  Show dependency treegraph
 
Reported: 2011-02-04 10:25 EST by Scott Mayhew
Modified: 2013-10-01 17:56 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:56:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Scott Mayhew 2011-02-04 10:25:06 EST
Description of problem:
On the ChannelCreateFiles.do page, directly under the Symbolic Link radio button, there is a tip that says:

Tip: Enter the target of the symlink as the file contents

This appears to be an old tip, as the target is now represented in a separate text box and the file contents text box is disabled when creating a symlink.

Version-Release number of selected component (if applicable):
5.4

How reproducible:
always

Steps to Reproduce:
1. Go to Configuration->Configuration Channels->Add Files->Create File
2.
3.
  
Actual results:


Expected results:
The tip should be removed

Additional info:
Comment 2 Tomas Lestach 2011-02-18 12:39:59 EST
I mean the tip wants to say that, if you have a symlink to a text file

symlink -> text_file

that you shall make sure to specify the path of the text_file, when modifying its contents and not the symlink path.

Or am I wrong?
Comment 4 Scott Mayhew 2011-04-08 14:19:09 EDT
I think the confusion arises from the use of the phrase "file contents" in the tip.  There is a field on the screen called "File Contents", and this field is disabled when creating a symbolic link type configuration file.

To ease the confusion, can we either get rid of the tip altogether or adopt the terminology from either the ln(1) or symlink(2) man pages?  For example:

Tip: Enter the LINK_NAME in the Filename/Path field and the TARGET in the Symbolic Link Target Filename/Path field.

or

Tip: Enter the newpath in the Filename/Path field and the oldpath in the Symbolic Link Target Filename/Path field.
Comment 9 Tomas Lestach 2012-11-26 11:51:30 EST
I've removed the confusing tip ...

spacewalk.git: 7f966b209d2bce5b99ba5a49870849ff3cc29de1
Comment 14 Clifford Perry 2013-10-01 17:56:49 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.