Bug 67525 - X-Server lhangs system for ATI Rage 128 AGP Video Card
X-Server lhangs system for ATI Rage 128 AGP Video Card
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
Blocks: 82779
  Show dependency treegraph
Reported: 2002-06-26 17:07 EDT by Eve Kovacs
Modified: 2007-04-18 12:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-05-30 19:44:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Output of X-server upon issuing startx (9.10 KB, text/plain)
2002-08-15 18:00 EDT, Eve Kovacs
no flags Details
/etc/X11/XF86Config-4 (1.75 KB, text/plain)
2002-08-15 18:02 EDT, Eve Kovacs
no flags Details
/etc/X11/XF86Config (12.39 KB, text/plain)
2002-08-15 18:03 EDT, Eve Kovacs
no flags Details
Output of "lspci -vn" (2.67 KB, text/plain)
2002-08-15 18:06 EDT, Eve Kovacs
no flags Details
Error log file on starting x-server (848 bytes, text/plain)
2002-08-28 17:56 EDT, Eve Kovacs
no flags Details
Complete log file from X-server startup (24.12 KB, text/plain)
2002-08-28 17:57 EDT, Eve Kovacs
no flags Details

  None (edit)
Description Eve Kovacs 2002-06-26 17:07:16 EDT
Description of Problem:
When I start the x-server for a 7.3 system with an ATI Rage 128 AGP video card,
the system hangs
and I have to do a hard reset.
This is the same problem that I saw in 7.2, but there has been an erratum
issued. No erratum has appeared for 7.3 yet.
Version-Release number of selected component (if applicable):

How Reproducible:

Steps to Reproduce:
1. Run Xconfigurator in expert mode, select ATI video card.
2. Boot in runlevel 3.	

3. Type startx

Actual Results:

Expected Results:

Additional Information:
Comment 1 Mike A. Harris 2002-07-10 02:03:16 EDT
Please provide much more details of this problem.  Your bug report
does not contain any useful information on reproducing this problem.

I've got many Rage 128 boards here for testing, and all work flawlessly
on RHL 7.1, 7.2, 7.3, and current rawhide.  I'll need specific details
of your specific hardware, and how to reproduce the problem.  I'll also
need a copy of your X config file and X server log.  Please provide
the output of "lspci -vn" also.
Comment 2 Mike A. Harris 2002-08-13 08:42:17 EDT
Closing bug due to lack of information and response inactivity.

If problem persists, please provide requested information and reopen.
Comment 3 Eve Kovacs 2002-08-15 18:00:43 EDT
Created attachment 70946 [details]
Output of X-server upon issuing startx
Comment 4 Eve Kovacs 2002-08-15 18:02:19 EDT
Created attachment 70947 [details]
Comment 5 Eve Kovacs 2002-08-15 18:03:42 EDT
Created attachment 70948 [details]
Comment 6 Eve Kovacs 2002-08-15 18:06:38 EDT
Created attachment 70949 [details]
Output of "lspci -vn"
Comment 7 Eve Kovacs 2002-08-15 18:14:43 EDT
I have provided the requested information. The XF86Config* files were generated
using Xconfigurator, and selecting the ATI Rage 128 AGP card and Hitachi CM715
One other piece of information: When the x-settings were tested during the
installation of 7.3,
they worked. Rebooting the system after installation (to runlevel3) and then
doing a startx caused the  system to hang. ie hard reset required. I then reran
Xconfigurator, and tried again with the same
Comment 8 Mike A. Harris 2002-08-25 08:38:40 EDT
From your log file:

>XFree86 Version 4.1.0 (Red Hat Linux release: 4.1.0-15) / X Window System
>(protocol Version 11, revision 0, vendor release 6510)
>Release Date: 2 June 2001

Red Hat Linux does not come with XFree86 4.1.0, it comes with
XFree86 4.2.0.  You seem to be using Red Hat Linux 7.2 with
an updated Xconfigurator from Red Hat Linux 7.3, or you're using
XFree86 4.1.0-15 from Red Hat Linux 7.[12] erratum in a Red Hat
Linux 7.3 system.  Either way, both configurations are not

XFree86 4.2.0 that ships with Red Hat Linux 7.3 should work
fine on this video card.  I've got one of these and have just
confirmed it works both with and without DRI enabled.  Ran
tuxracer for a while, and Return to Castle Wolfenstein.

Please properly upgrade your system to a full Red Hat Linux 7.3
install, and try out X 4.2.0 and let me know if it works for you.

Comment 9 Eve Kovacs 2002-08-28 17:56:15 EDT
Created attachment 73614 [details]
Error log file on starting x-server
Comment 10 Eve Kovacs 2002-08-28 17:57:22 EDT
Created attachment 73615 [details]
Complete log file from X-server startup
Comment 11 Eve Kovacs 2002-08-28 18:00:53 EDT
Mea Culpa. I accidentally attached the startx output made when the system was
still at Redhat 7.1
I have attached 2 new log files, called startx.delphi and XFree86.0.log, which
document the 
error on starting the xserver for the redhat 7.3 system. As you can see, the
version of XFree is correct..
Comment 12 Mike A. Harris 2003-02-05 19:44:21 EST
If this problem is still present, please attach your kernel log file
/var/log/messages, the output of "lsmod" and "lspci -vvn".

Also, if you're running a new release such as Red Hat Linux 8.0 or our
phoebe beta release, or are willing to try them and provide feedback
of the current status of this problem, I can investigate it further.

Thanks in advance.
Comment 13 Mike A. Harris 2003-05-14 07:20:49 EDT
I am unable to make the system lock up using the information provided above
on an identical video card.  I've tested it on RHL 7.3, 8.0, and 9 and
it works fine on all 3 systems.  (One system with 3 OS versions installed

The final log file you have provided shows things hanging when DRI is
initialized, which leads me to believe that the kernel DRM is failing for
some reason for you.  If this is the case, you can disable DRI in the config
file in order to work around the problem.

Another option is upgrading your system to Red Hat Linux 9, and seeing if
the problem goes away.

At any rate, I can't reproduce this, and it has been over 3 months since
I requested information from you in my last comment, so I'm assuming that
you've either got it working somehow, have upgraded, or the problem isn't
critical to you anymore.

Closing bug as CURRENTRELEASE (upgrade to the current release of
Red Hat Linux 9)
Comment 14 Eve Kovacs 2003-05-22 18:12:48 EDT
I just tried upgrading this system to Redhat 9. I tried booting from the CD and
entering both graphical mode and text mode. In either case the upgrade hung
almost immediately, just after loading the aic7xxx driver for the scsi
controller. I had to push the reset button to get out of this state. I realize
this is not the same bug, but the saga goes on. There are no error messages to
help me resolve this problem. The only other crash I have had with a Redhat
install was on another system with an AGP video card. I resolved that one by
exchanging the card for the install, and then replacing it once the system was
upgraded. I am going to try the same thing here. I realize this is not the same
bug, but since this was a proposed solution to my problem, I am going to reopen
the bug.
Comment 15 Mike A. Harris 2003-05-22 18:47:14 EDT
>almost immediately, just after loading the aic7xxx driver for the scsi
>controller. I had to push the reset button to get out of this state. I realize

The system is locking up after loading the SCSI driver?  How is this an
XFree86 bug?
Comment 16 Eve Kovacs 2003-05-30 19:44:27 EDT
I have now tried 2 different video cards in the system. I tried another AGP card
which I have used before on a system I WAS able to upgrade to Redhat 9. This time 
the upgrade hung as before. Then, I switched to a PCI card (ATI Expert Rage 128).
This fixed the problem. The upgrade proceeded normally, and I was able to see
that the point where it hung before was the point at which it probed the video card.

I don't know what the exact problem was with this system. At this point I am
happy with the PCI card. However, as I mentioned above, this is not the first
time I have seen problems with AGP cards. 

Note You need to log in before you can comment on or make changes to this bug.