Bug 675389 - apache-commons-configuration does not rebuild
Summary: apache-commons-configuration does not rebuild
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: apache-commons-configuration
Version: 14
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Stanislav Ochotnicky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-05 11:22 UTC by Christoph Karl
Modified: 2011-02-27 14:52 UTC (History)
7 users (show)

Fixed In Version: apache-commons-configuration-1.6-3.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-24 06:27:08 UTC


Attachments (Terms of Use)
log file of rebuild (56.70 KB, text/plain)
2011-02-05 11:22 UTC, Christoph Karl
no flags Details
Patch adding ant groupId (11.17 KB, patch)
2011-02-09 17:45 UTC, Stanislav Ochotnicky
no flags Details | Diff

Description Christoph Karl 2011-02-05 11:22:58 UTC
Created attachment 477179 [details]
log file of rebuild

Description of problem:
apache-commons-configuration does not rebuild.
Maybe due to missing ant.jar

Version-Release number of selected component (if applicable):
apache-commons-configuration-1.6-2.fc14.src.rpm

How reproducible:
always

Steps to Reproduce:
1. mock -r ck --rebuild apache-commons-configuration-1.6-2.fc14.src.rpm
OR
1. rpm -i apache-commons-configuration-1.6-2.fc14.src.rpm
2. rpmbuild -bb rpmbuild/SPECS/apache-commons-configuration.spec
  
Actual results:
see log file

Expected results:
clean rebuild

Additional info:

Comment 1 Stanislav Ochotnicky 2011-02-09 17:22:14 UTC
This is actually an ant problem with add_to_maven_depmap call. GroupId is always org.apache.ant but some packages require older groupId of ant. Reassigning.

Comment 2 Stanislav Ochotnicky 2011-02-09 17:45:06 UTC
Created attachment 477872 [details]
Patch adding ant groupId

This patch should add correct backward compatible groupId, I haven't tested it though. You can apply it using:
$ git am 0001-Add-backward-compatible-ant-groupId-for-maven.patch

Comment 3 Alexander Kurtakov 2011-02-13 12:03:50 UTC
This is not ant problem but apache-commons-configuration one. I've opened a bug report about it upstream see https://issues.apache.org/jira/browse/CONFIGURATION-436 .
Ant 1.7.0(with the new groupId) was released more than 4 years ago and projects were supposed to adapt by now.
Changing the component to apache-commons-configuration.

Comment 4 Fedora Update System 2011-02-15 14:38:29 UTC
apache-commons-configuration-1.6-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/apache-commons-configuration-1.6-3.fc14

Comment 5 Fedora Update System 2011-02-15 21:24:43 UTC
apache-commons-configuration-1.6-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update apache-commons-configuration'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/apache-commons-configuration-1.6-3.fc14

Comment 6 Fedora Update System 2011-02-24 06:27:03 UTC
apache-commons-configuration-1.6-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Christoph Karl 2011-02-27 14:52:49 UTC
"apache-commons-configuration-1.6-3.fc14.src.rpm" works for me.


Note You need to log in before you can comment on or make changes to this bug.