This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 675481 - Fallback mode kicks in on systems where Shell runs fine
Fallback mode kicks in on systems where Shell runs fine
Status: CLOSED DUPLICATE of bug 679326
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
rawhide
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-05 17:29 EST by Stéphane Démurget
Modified: 2011-03-07 18:46 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-07 18:45:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
glxinfo from my affected system (18.99 KB, text/plain)
2011-02-16 14:16 EST, Adam Williamson
no flags Details

  None (edit)
Description Stéphane Démurget 2011-02-05 17:29:11 EST
Description of problem:

Using the test day i686 iso with the nouveau driver, the classical gnome session is started. But when I use 'gnome-shell --replace' directly in a terminal after being logged in, everything works like a charm. The animations are really smooth and I completed all the other tests of the Gnome3 TestDay successfully under gnome-shell.

Maybe my graphic card (an NV34M GeForce FX Go5200 32M/64M) is blacklisted?
Or there is a delay to test 3d support and I used a DVD?

Can I test something else to find out why the gnome-shell session was not picked up?

Smolt profile: http://www.smolts.org/client/show/pub_6d069d23-3a91-4505-ba4a-4e9a983e774c


Version-Release number of selected component (if applicable):

Gnome3 Alpha Test Day i686 iso.

How reproducible:
Always

Steps to Reproduce:
1. Boot with the iso burnt on a dvd.
2. Login using the livecd user through gdm
3.
  
Actual results:
Classical gnome 3 (panel + nautilus) is started.

Expected results:
Gnome-shell should be started.
Comment 1 Adam Williamson 2011-02-16 14:15:23 EST
I have the same issue with my Rawhide desktop ATM. It uses a [GeForce 9400 GT] [10de:0641]. Boot gives me fallback mode, but gnome-shell --replace gives me a perfectly working Shell. This hasn't always happened; a month or so back, it'd boot happily straight to shell. Looks like some of the fallback heuristics are a bit too trigger-happy. Attaching glxinfo in case it helps.
Comment 2 Adam Williamson 2011-02-16 14:16:23 EST
Created attachment 479199 [details]
glxinfo from my affected system
Comment 3 Adam Williamson 2011-02-20 12:11:31 EST
~/.xsession-errors shows:

[adamw@adam ~]$ grep acceler .xsession-errors
gnome-session[2087]: WARNING: Had to kill '/usr/libexec/gnome-session-is-accelerated' helper
[adamw@adam ~]$ 

if I run it manually after logging in, it runs and exits very quickly.
Comment 4 Adam Williamson 2011-03-07 18:45:46 EST
this is probably a case of 679326, which has more detail though it's a 'later' report.

*** This bug has been marked as a duplicate of bug 679326 ***
Comment 5 Adam Williamson 2011-03-07 18:46:42 EST
drop keyword

Note You need to log in before you can comment on or make changes to this bug.