Bug 675629 - [abrt] planner-0.14.4-31.fc15: Process /usr/bin/planner was killed by signal 11 (SIGSEGV)
Summary: [abrt] planner-0.14.4-31.fc15: Process /usr/bin/planner was killed by signal ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: planner
Version: 15
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4d3b4a3625022953c3c374f490c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-07 00:34 UTC by Luya Tshimbalanga
Modified: 2011-03-03 03:30 UTC (History)
1 user (show)

Fixed In Version: planner-0.14.4-34.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-03 03:30:51 UTC


Attachments (Terms of Use)
File: backtrace (15.58 KB, text/plain)
2011-02-07 00:34 UTC, Luya Tshimbalanga
no flags Details
Planner crash video (1.98 MB, video/ogg)
2011-02-11 06:39 UTC, Luya Tshimbalanga
no flags Details

Description Luya Tshimbalanga 2011-02-07 00:34:05 UTC
abrt version: 1.1.14
architecture: i686
Attached file: backtrace
cmdline: planner
comment: Traceback happened when attempting to move duration bar with milestone selected.
component: planner
executable: /usr/bin/planner
kernel: 2.6.37-2.fc15.i686
package: planner-0.14.4-31.fc15
reason: Process /usr/bin/planner was killed by signal 11 (SIGSEGV)
release: Fedora release 15 (Rawhide)
time: 1297038730
uid: 500

How to reproduce
-----
1. Create new task
2. Attempt to drag progress bar with milestone selected.
3.

Comment 1 Luya Tshimbalanga 2011-02-07 00:34:10 UTC
Created attachment 477363 [details]
File: backtrace

Comment 2 Caolan McNamara 2011-02-08 11:23:02 UTC
symbols are unfortunately missing. I can't reproduce this with a simple example. Are you able to reproduce this ?

Comment 3 Luya Tshimbalanga 2011-02-08 21:47:08 UTC
Yes.
1. Create a new task.
2. Select Note tab and attempt to input a text.
Crash should occur.

Comment 4 Caolan McNamara 2011-02-10 10:02:37 UTC
Nope, no crash for me. I'm probably failing to do this in the right way, any chance you could attach an example that fails when you try it.

Comment 5 Luya Tshimbalanga 2011-02-11 06:39:46 UTC
Created attachment 478188 [details]
Planner crash video

Reproducing the crash via video

Comment 6 Caolan McNamara 2011-02-16 10:06:49 UTC
Thanks for the video. Strangely enough this doesn't crash here, but valgrind is giving me a likely candidate for this crash. Let me try and fix that, and make an update and see if it fixes your crash.

Comment 7 Caolan McNamara 2011-02-16 10:42:04 UTC
Reported during f15, so building into that. Hopefully 0.14.4-34.fc15 resolves this for you. 

If it doesn't then please reopen and try...

export G_SLICE=always-malloc
sudo yum -y install valgrind
valgrind planner > /tmp/valgrind.log 2>&1

and attach that output

Comment 8 Fedora Update System 2011-02-16 10:59:46 UTC
planner-0.14.4-34.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/planner-0.14.4-34.fc15

Comment 9 Fedora Update System 2011-02-16 14:20:29 UTC
planner-0.14.4-34.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update planner'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/planner-0.14.4-34.fc15

Comment 10 Fedora Update System 2011-03-03 03:30:45 UTC
planner-0.14.4-34.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.