Bug 675733 - Debian 6.0 within a DomU, RHEL5.6 as Dom0
Summary: Debian 6.0 within a DomU, RHEL5.6 as Dom0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen
Version: 5.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Michal Novotny
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 691391 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-07 15:13 UTC by Florian La Roche
Modified: 2014-02-02 22:38 UTC (History)
8 users (show)

Fixed In Version: xen-3.0.3-124.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-21 09:13:22 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch to support grub2(hdX/msdosY) style partition definition (1.17 KB, patch)
2011-02-16 13:51 UTC, Michal Novotny
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1070 0 normal SHIPPED_LIVE xen bug fix and enhancement update 2011-07-21 09:12:56 UTC

Description Florian La Roche 2011-02-07 15:13:13 UTC
Description of problem:

Running an installation of Debian-6 with grub2 does not give a running
DomU. Most patches for this are included in RHEL5.6, but the following
patch could still be added:

  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=599243

best regards,

Florian La Roche




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Michal Novotny 2011-02-08 12:42:46 UTC
Florian,
where can I get the images of Debian 6.0 to install as a PV guest? The only installation I'm having is an ISO image for HVM net installation and nothing else. Do you have any pointers where to find the images for PV guest installation?

Thanks,
Michal

Comment 2 Florian La Roche 2011-02-08 14:10:42 UTC
Hello Michal,

basic info is available at http://wiki.debian.org/Xen

Even shorter:
wget http://ftp.debian.org/debian/dists/squeeze/main/installer-i386/current/images/netboot/xen/xm-debian.cfg

Maybe set the following items: memory, name, vif, disk and
change to bootloader="/usr/bin/pygrub" in that script.

Then start an installation with:
xm create -c xm-debian.cfg install=true \
  install-mirror="http://ftp.de.debian.org/debian" \
  install-extra="auto=true hostname=debian domain=cz.redhat.com"
Maybe also set "install-arch=amd64"...

Then first reboot should be with "xm create -c xm-debian.cfg" that should need
the above fix to work correctly.

best regards,

Florian La Roche

Comment 3 Michal Novotny 2011-02-16 13:51:57 UTC
Created attachment 479113 [details]
Patch to support grub2(hdX/msdosY) style partition definition

Hi,
this is the patch to support "(hdX, msdosY)" partition syntax for grub. This has been tested on RHEL-5 dom0 with Debian-6.0 PV guest and without this patch applied
it failed with error message that msdos1 is not a valid int but with this patch applied the guest booted up successfully.

Michal

Comment 8 Yufang Zhang 2011-03-22 02:04:43 UTC
QA verified this bug with xen-3.0.3-126.el5:

1. install a PV debian guest os according to comment #2.

2. boot the guest after os installation, the guest could boot successfully.


So change this bug to VERIFIED.

Comment 9 Michal Novotny 2011-03-29 10:54:51 UTC
*** Bug 691391 has been marked as a duplicate of this bug. ***

Comment 10 errata-xmlrpc 2011-07-21 09:13:22 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1070.html

Comment 11 errata-xmlrpc 2011-07-21 12:07:34 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1070.html


Note You need to log in before you can comment on or make changes to this bug.