Bug 67576 - Redhat 7.3: gv slow.
Redhat 7.3: gv slow.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gv (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-27 14:03 EDT by phil
Modified: 2014-03-16 22:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-22 16:43:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
postscript file - first page from a technical report. (54.25 KB, text/plain)
2002-06-27 14:05 EDT, phil
no flags Details

  None (edit)
Description phil 2002-06-27 14:03:01 EDT
Description of Problem:
gv runs quite slowly under Redhat 7.3, displaying text
a line at a time.  It was much faster under 7.2 and prior.

Version-Release number of selected component (if applicable):
gv 3.5.8
GNU Ghostscript 6.52 (2001-10-20)

How Reproducible:
Always.

Steps to Reproduce:
1.  use gv to view the attached postscript file.  (p1.ps).
2.  compare the result with using gv p1.ps on Redhat 7.2 and prior. 
 
Actual Results:
gv displays the text very slowly.

Expected Results:
gv displays much faster under Redhat 7.2 and prior.

Additional Information:
I found that if i did 'gv -noantialias p1.ps', it displays much faster.
However, it doesn't look as good.
So something in the antialiasing appears to be making it run slowly.
The probelm appears to be in gv. gs p1.ps runs quickly.

The attached sample p1.ps is the first page from a technical report here.

Thanks for your help.

Phil Kaslo
phil@cs.arizona.edu
Comment 1 phil 2002-06-27 14:05:11 EDT
Created attachment 62905 [details]
postscript file - first page from a technical report.
Comment 2 Matthew West 2002-08-22 16:42:56 EDT
This seems to have been caused by a change in the file:
/usr/X11R6/lib/X11/app-defaults/GV

Find the line which reads:
GV.gsX11AlphaDevice: -dNOPLATFONTS -sDEVICE=x11 -dTextAlphaBits=4 -
dGraphicsAlphaBits=4

and change it to:
GV.gsX11AlphaDevice: -dNOPLATFONTS -sDEVICE=x11alpha

This changes things back to how they were under 7.2 and makes gv fast again.
Comment 3 Bill Nottingham 2002-08-22 21:22:30 EDT
Yes, this is fixed in the beta gv.

Note You need to log in before you can comment on or make changes to this bug.