Bug 675767 - Unable to send Ctrl+Alt+key shortcut to a Guest
Unable to send Ctrl+Alt+key shortcut to a Guest
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-client (Show other bugs)
6.1
All Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Uri Lublin
Desktop QE
: Regression, Reopened
Depends On:
Blocks: 675768
  Show dependency treegraph
 
Reported: 2011-02-07 12:06 EST by Marian Krcmarik
Modified: 2012-08-09 18:41 EDT (History)
5 users (show)

See Also:
Fixed In Version: spice-client-0.8.0-2.el6
Doc Type: Bug Fix
Doc Text:
When a spice-client hotkey was set to Ctrl+Alt, users were unable to send, using Sticky-Alt, a Ctrl+Alt+key key sequence to a guest. That prevented various functionality such as switching focus to the console or setting keyboard shortcuts. This bug has been fixed and users can send the client a key sequence with Ctrl and Alt keys using Sticky-Alt even if a spice-client hotkey is set to Ctrl+Alt.
Story Points: ---
Clone Of:
: 675768 (view as bug list)
Environment:
Last Closed: 2011-05-19 09:15:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marian Krcmarik 2011-02-07 12:06:22 EST
Description of problem:
It's not able to send Ctrl+Alt+key shortcut to a Guest (Both RHEL and Windows)

Version-Release number of selected component (if applicable):
spice-client-0.7.2-1.el6.x86_64
qspice-libs-0.3.0-54.el5_5.2
kvm-83-224.el5
(RHEVM2.3 only)

How reproducible:
Always

Steps to Reproduce:
1. Log in RHEL guest or Windwos guest with using spice client running on RHEL6.
2. Try to use Ctrl+Alt+key (for example switching to console or setting keyboard shortcut, unlocking session in Windows).
  
Actual results:
Last key will be sent to a guest.

Expected results:
Whole shortcut should be sent to a guest.

Additional info:
* It does work with RHEVM22, qspice-libs-0.3.0-54.el5.5.2, kvm-83-164.el5_5.23.
* Works with Windows client.
* Gnome keyboard shortcut returns only last key.
Comment 3 Uri Lublin 2011-02-13 07:45:09 EST
It seems the problem is that pressing ctrl releases the sticky-alt.
Comment 4 Hans de Goede 2011-02-27 09:22:57 EST
I've tried to reproduce this with the 0.7.2 X11 client and it works fine for me. Also this is all handled on the client side, so it working when connecting to a RHEV-2.2 host, and not when connecting to a RHEV-2.3 host seems weird.

Closing this as works for me. Please re-open with some more detailed information (such as indicating package versions on all 3 of guest, host and client) if you are still seeing this.

You are aware of the use of sticky alt to send special key combis like this ? Keep alt pressed until an ALT icon overlay shows in the center of the client then press ctrl + key to send alt + ctrl + key.
Comment 5 Lubos Kocman 2011-03-10 09:25:01 EST
Reproduced again

My setup is:

spice-client-0.8.0-1.el6.x86_64
qemu-kvm-0.12.1.2-2.149.el6.x86_64
Guest == win7x32 with ic104 guest tools
Comment 6 Lubos Kocman 2011-03-10 09:25:59 EST
^ -- Connected trough UserPortal from RHEVM 2.3 (4.6.0.276)
Comment 7 Lubos Kocman 2011-03-10 09:50:43 EST
^ -- spice-server-0.7.3-2.el6.x86_64
Comment 8 Lubos Kocman 2011-03-10 10:49:29 EST
Same happens with rhel6 guest. Sticky alt is released right after ctrl is pressed.
Comment 9 Hans de Goede 2011-03-10 14:05:00 EST
I've been debugging this some more on my local F-14 installation. I've replaced my qemu and spice-server packages with those from RHEL-6.1 but I still cannot reproduce this using a local vm. Next I tried both with and without an agent, no success again.

So either this is something on the host (I can reproduce by connecting to
rhevm23.spice.lab...) outside of qemu + spice-server, or more likely IMHO, this is something in the way how RHEV-M invokes qemu / sets up the connection (ssl versus plain ?) between spice-server and spice-client.

lkocman, can you please try to reproduce this using a locally hosted vm rather then by connecting to rhev-m? It might be a good idea to try and mimick the rhev-m qemu invokation as much as possible.

I'll go debug the client against rhevm23.spice.lab... tomorrow.
Comment 10 Uri Lublin 2011-03-10 22:05:22 EST
Works for me on a RHEL-6 host with (modified/development) spice-server and qemu-kvm and with RHEL-6.1 guest and win764 (not sure about tools), not using rhev-m.


spice-server-0.8.0-1.el6.x86_64 -- modified (probably unrelated changes)
qemu-kvm-0.12.1.2-2.149.el6     -- modified (probably unrelated changes)
spice-client-0.7.3-1.el6.x86_64
Comment 11 Lubos Kocman 2011-03-11 04:51:12 EST
As hansg said it seems to be spice-server or qemu specific:

so are you able to reproduce it with spice-server-0.7.3-2.el6.x86_64 and qemu-kvm-0.12.1.2-2.149.el6.x86_64?
Comment 12 Hans de Goede 2011-03-11 09:06:14 EST
Ok, so after a day of trying with various versions to reproduce this, I can only reproduce it when RHEV-M is involved, further debugging has shown that the cause is that RHEV-M now sets the spicec hotkeys (through the XPI) to be ctrl+alt for
release cursor (and no other hotkeys for ie fullscreen). This is also the cause of bug 683823. But unlike with 683823 in this case we can do something, as we can at least make sure that sending ctrl + alt + other-key still works using sticky-alt.

I've a patch for this:
http://cgit.freedesktop.org/spice/spice/commit/?id=9d204f8b74c8fbcc6a508f956e9c483e98ce653d

Devel-acking.
Comment 13 Hans de Goede 2011-03-11 10:21:27 EST
New version with the patch fixing this in build, moving to modified.
Comment 16 Tomas Capek 2011-05-17 07:31:17 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
When a spice-client hotkey was set to Ctrl+Alt, users were unable to send, using Sticky-Alt, a Ctrl+Alt+key key sequence to a guest. That prevented various functionality such as switching focus to the console or setting keyboard shortcuts. This bug has been fixed and users can send the client a key sequence with Ctrl and Alt keys using Sticky-Alt even if a spice-client hotkey is set to Ctrl+Alt.
Comment 17 errata-xmlrpc 2011-05-19 09:15:30 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0583.html

Note You need to log in before you can comment on or make changes to this bug.