Bug 675804 - [abrt] gtk-redshift-1.5-1.fc14: utils.py:20:<module>:ImportError: No module named xdg
Summary: [abrt] gtk-redshift-1.5-1.fc14: utils.py:20:<module>:ImportError: No module n...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: redshift
Version: 14
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miloš Komarčević
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:cb53959b
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-07 19:46 UTC by Rovanion Luckey
Modified: 2011-03-10 20:52 UTC (History)
1 user (show)

Fixed In Version: redshift-1.6-3.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-09 03:11:15 UTC


Attachments (Terms of Use)
File: backtrace (6.72 KB, text/plain)
2011-02-07 19:46 UTC, Rovanion Luckey
no flags Details

Description Rovanion Luckey 2011-02-07 19:46:23 UTC
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
component: redshift
executable: /usr/bin/gtk-redshift
kernel: 2.6.35.6-45.fc14.x86_64
package: gtk-redshift-1.5-1.fc14
reason: utils.py:20:<module>:ImportError: No module named xdg
release: Fedora release 14 (Laughlin)
time: 1297107324
uid: 501

How to reproduce
-----
1. Install Fedora 14 KDE
2. Install redshift and gtk-redshift from the official repositories
3. Run gtk-redshift

Comment 1 Rovanion Luckey 2011-02-07 19:46:25 UTC
Created attachment 477490 [details]
File: backtrace

Comment 2 Miloš Komarčević 2011-02-07 22:52:16 UTC
Hm, looks like the KDE desktop install is missing the "pyxdg" package, try installing it manually. Will add it as a dep in the next gtk-redshift release.

P.S. Not sure if gtk-redshift will even integrate in the KDE tray, you might have to run CLI only...

Comment 3 Rovanion Luckey 2011-02-08 15:13:05 UTC
Installed pyxdg and ran it. Turns out that it doesn't work with the KDE tray.

Comment 4 Fedora Update System 2011-03-02 17:41:13 UTC
Package redshift-1.6-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing redshift-1.6-3.fc15'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/redshift-1.6-3.fc15
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2011-03-02 17:41:25 UTC
Package redshift-1.6-3.fc14:
* should fix your issue,
* was pushed to the Fedora 14 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing redshift-1.6-3.fc14'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/redshift-1.6-3.fc14
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2011-03-02 17:41:36 UTC
Package redshift-1.6-3.fc13:
* should fix your issue,
* was pushed to the Fedora 13 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing redshift-1.6-3.fc13'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/redshift-1.6-3.fc13
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2011-03-03 02:56:32 UTC
redshift-1.6-3.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update redshift'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/redshift-1.6-3.fc15

Comment 8 Fedora Update System 2011-03-09 03:11:06 UTC
redshift-1.6-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-03-10 20:48:10 UTC
redshift-1.6-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-03-10 20:52:05 UTC
redshift-1.6-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.