Bug 67581 - Fdisk will not create more than 16 partitions
Summary: Fdisk will not create more than 16 partitions
Status: CLOSED DUPLICATE of bug 56244
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-27 19:21 UTC by Bryan K. Reed
Modified: 2007-04-18 16:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-27 19:21:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bryan K. Reed 2002-06-27 19:21:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011221

Description of problem:
Fdisk will not let you create more than 16 partitions on an IDE drive.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.fdisk /dev/hda
2.keep creating partitions.  Won't let you create any beyond 16
3.
	

Expected Results:  With the util-linux that came with 6.2 we could create many
more partitions than we can now (on IDE).  

Additional info:

I went and looked at the source code.  There's a patch in the src rpm that
changes MAXIMUM_PARTS in fdisk.h from 80 to 16
(util-linux-2.11n-miscfixes.patch.)   I didn't see any comments in the RPM spec
file that mentioned why this was done.

Comment 1 Elliot Lee 2002-06-27 20:32:25 UTC

*** This bug has been marked as a duplicate of 56244 ***


Note You need to log in before you can comment on or make changes to this bug.