Bug 67589 - rmb title-bar click doesn't bring focus
rmb title-bar click doesn't bring focus
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: metacity (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-27 16:28 EDT by Preston Brown
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-24 18:26:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preston Brown 2002-06-27 16:28:24 EDT
Havoc: 
 
not sure if you consider this a bug, but I do. 
 
If you rmb click on a title bar to bring up the context menu for a window, that window 
doesn't get focus if it doesn't have it already. 
 
2.3.987-3 is the ver. 
 
Also, as an aside:  I think you made a policy decision that new windows that are mapped 
shouldn't get focus.  This is counter to motif, counter to old sawfish, counter to kde, and 
counter to windows.  And it is counter to what I'm used to and very confusing. Is it going 
to stay that way?
Comment 1 Havoc Pennington 2002-07-04 00:10:50 EDT
Right click thing is http://bugzilla.gnome.org/show_bug.cgi?id=87299
(I can't think of a case where it matters, but I guess it makes it clearer which
window you are opening the menu for).

For focusing new windows, I was copying the Windows XP policy. It just doesn't
work on UNIX because people don't mark their dialogs as such. I've given up on
it since.
Comment 2 Havoc Pennington 2002-07-12 19:16:13 EDT
There's a patch on the upstream bug I need to apply.
Comment 3 Havoc Pennington 2002-08-24 18:26:11 EDT
was committed to upstream a while ago and is in our package.
Comment 4 Jay Turner 2002-08-28 20:10:40 EDT
Fix confirmed with metacity-2.4.0.92-4.

Note You need to log in before you can comment on or make changes to this bug.