Bug 675949 - ant can't find antRun
Summary: ant can't find antRun
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ant
Version: 19
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Mikolaj Izdebski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1003072
TreeView+ depends on / blocked
 
Reported: 2011-02-08 12:08 UTC by fropeter
Modified: 2013-09-03 17:46 UTC (History)
6 users (show)

Fixed In Version: 1.9.2-6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1003072 (view as bug list)
Environment:
Last Closed: 2013-09-03 17:46:31 UTC


Attachments (Terms of Use)
Proposed patch (1.99 KB, patch)
2013-08-30 16:58 UTC, Mikolaj Izdebski
no flags Details | Diff

Description fropeter 2011-02-08 12:08:24 UTC
Description of problem:

The bug
    https://bugzilla.redhat.com/show_bug.cgi?id=428502
is reproducible in fedora 14

Version-Release number of selected component (if applicable):

Apache Ant version 1.7.1 compiled on April 16 2010

How reproducible:
See original bug report


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Ant fails to build, complaining about missing /usr/share/ant/bin/antRun

Expected results:
Ant finds the file and completes the build successfully


Additional info:

Fix: 
# create the directory /usr/share/ant/bin
# symlink the file /usr/bin/antRun to /usr/share/ant/bin/antRun

Comment 1 Alexander Kurtakov 2011-07-06 10:58:51 UTC
Do you have ant-scripts installed? This is where antRun is shipped. It is in /usr/bin. Let us know if installing ant-scripts helps.

Comment 2 Paul Milliken 2011-07-12 08:58:53 UTC
Not the original poster. I'm on Fedora 15 and experiencing the same problem, hopefully the information I can give will be of use.

My build bombs out with: 

Execute failed: java.io.IOException: Cannot run program "/usr/share/ant/bin/antRun": java.io.IOException: error=2, No such file or directory

I don't have the ant-scripts package installed, however:

[paul.milliken@besaid pide]$ which antRun
/usr/bin/antRun
[paul.milliken@besaid pide]$ rpm -qf `which antRun`
ant-1.8.2-3.fc15.noarch

it seems that antRun comes with the main ant package. However, I install ant-scripts using yum, then checked it:

[paul.milliken@besaid pide]$ rpm -ql ant-scripts
/usr/bin/antRun.pl
/usr/bin/complete-ant-cmd.pl
/usr/bin/runant.pl
/usr/bin/runant.py

and tried my build again. Which failed in the same manner.

It looks (to me) like antRun is installed, but isn't where the rest of ant expects it to be.

Comment 3 fropeter 2011-08-20 15:04:00 UTC
Apologies for the delayed response.

I'm on Fedora 15 now, ant-scripts is installed and the problem still exists.
Ant does not find the installed antRun in /usr/bin, but reports it missing from /usr/share/ant/bin. 

$ locate antRun reports 
/usr/bin/antRun

(and some other entries too, but it exists where it should be.)

In /usr/share/ant/ there is no bin/ directory, but creating it and symlinking /usr/bin/antRun into it is a workaround to the problem.

I can probably confirm this on F14 as well later, but since it's not solved on F15 it is probably the same as before.

Should this bug report be changed to applying to F15?

Comment 4 fropeter 2011-08-20 15:39:23 UTC
I'm on Fedora 14 now and the problem still exists.
ant-scripts is installed and antRun is in /usr/bin.
Workaround still works.

Comment 5 Fedora End Of Life 2012-08-16 15:04:39 UTC
This message is a notice that Fedora 14 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 14. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained.  At this time, all open bugs with a Fedora 'version'
of '14' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this 
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen 
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we were unable to fix it before Fedora 14 reached end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" (top right of this page) and open it against that 
version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Dhiru Kholia 2013-07-10 08:00:19 UTC
Problem still exists under Fedora 19. How hard is it to fix this seemingly trivial bug?

Comment 7 Alexander Kurtakov 2013-07-10 08:19:53 UTC
(In reply to Dhiru Kholia from comment #6)
> Problem still exists under Fedora 19. How hard is it to fix this seemingly
> trivial bug?
We are always happy to apply patches for the trivial bugs. It's the perfect way to get engaged with the community. 
git formatted patch is preferred.

Comment 8 Mikolaj Izdebski 2013-08-30 16:58:32 UTC
Created attachment 792257 [details]
Proposed patch

Comment 9 Mikolaj Izdebski 2013-09-03 17:21:09 UTC
Fixed in ant-1.9.2-6

Comment 10 Mikolaj Izdebski 2013-09-03 17:46:31 UTC
I believe that this bug is fixed in ant-1.9.2-6,
which is available in Fedora 20, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=461275

This bug was fixed in the next release of Fedora, and is not planned
to be fixed in the release it was filed against.  If you want this bug
to be fixed in updates for Fedora 19, please say so in a comment.
Otherwise you can update to the newer release of Fedora to get the fix.


Note You need to log in before you can comment on or make changes to this bug.