Bug 67600 - gnome-hint warns about font, shows no motd or fortune
gnome-hint warns about font, shows no motd or fortune
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-27 19:17 EDT by Erik Sxe Sxrensen
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-27 19:17:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik Sxe Sxrensen 2002-06-27 19:17:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
When running gnome-hint with '--browse-motd' or '--browse-fortune',
no MOTD or fortune cookie is shown - just a blank rectangle. The heading
(fortune) is shown, though (although it reads 'spekage'~'fortune cookie' in both
cases...)
The program complains about the available fonts in the MOTD and fortune cases.
With --browse-hints, everything works as it should.
(this went wrong when I upgraded from 7.1(2?) to 7.3)


Version-Release number of selected component (if applicable):
Gnome gnome-hint 1.4.0.4

How reproducible:
Always

Steps to Reproduce:
1. Make sure fortune is installed and/or you have a non-empty /etc/motd.
2. Have locale 'da_DK'.
3. Run 'gnome-hint --browse-motd' or 'gnome-hint --browse-fortune'.
Also, have normal ISO8859-1 fonts (XFree86-{75,100}dpi-fonts) installed.


Actual Results:  The window is shown, as expected, but without any text except
for the white-on-blue heading. The white rectangle below the heading is blank.
Also, the error message [Add. info] is printed (when gnome-hint is run from a
terminal), complaining about the font - which is weird, because it does not
object when being passed --browse-hints instead.

Expected Results:  The window should have contained a MOTD or a fortune (duh),
and not printed any error message.

Additional info:

/---- Error message:
The font "fast" does not support all the required character sets for the current
locale "da_DK"
  (Missing character set "ISO8859-1")
  (Missing character set "ISO8859-1")
\----
Comment 1 Havoc Pennington 2002-07-14 21:33:56 EDT
gnome-hint no longer exists in Rawhide.

Note You need to log in before you can comment on or make changes to this bug.