This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 676025 - anaconda crashes in text mode on creating boot loader
anaconda crashes in text mode on creating boot loader
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Brian Lane
Release Test Team
:
: 688351 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-08 11:26 EST by Martin Jürgens
Modified: 2011-12-06 05:29 EST (History)
4 users (show)

See Also:
Fixed In Version: anaconda-13.21.123-1
Doc Type: Bug Fix
Doc Text:
Users performing an upgrade using the Anaconda's text mode interface who do not have a boot loader already installed on the system, or who have a non-GRUB boot loader, need to select Skip Boot Loader Configuration during the installation process. Boot loader configuration will need to be completed manually after installation. This problem does not affect users running Anaconda in the graphical mode (graphical mode also includes VNC connectivity mode).
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 05:29:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pholica: needinfo-


Attachments (Terms of Use)
anaconda traceback (154.52 KB, text/plain)
2011-02-08 11:26 EST, Martin Jürgens
no flags Details

  None (edit)
Description Martin Jürgens 2011-02-08 11:26:40 EST
Created attachment 477642 [details]
anaconda traceback

Description of problem:
anaconda crashes in text mode on creating boot loader

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start anaconda in text mode using upgradeany with a different bootloader installed in mbr
2.  anaconda offers to replace it
  
Actual results:
crash, see trackback

Expected results:
should work fine as it does in graphical mode.

Additional info:
Comment 2 Chris Lumens 2011-03-16 14:51:43 EDT
This is fixed by 63fb1731cd77976f99b42dbf2c3598821b7faaff from master, which may or may not apply too well to rhel6-branch.
Comment 3 Chris Lumens 2011-03-16 16:55:23 EDT
*** Bug 688351 has been marked as a duplicate of this bug. ***
Comment 4 RHEL Product and Program Management 2011-05-13 19:08:00 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.
Comment 5 Charlie Brady 2011-06-10 11:43:34 EDT
(In reply to comment #2)
> This is fixed by 63fb1731cd77976f99b42dbf2c3598821b7faaff from master, which
> may or may not apply too well to rhel6-branch.

That should be a question which is easy to resolve. Does it or does it not apply?
Comment 6 Charlie Brady 2011-06-10 11:48:42 EDT
The answer is "yes" - it does apply:

bash-3.2$ lynx -dump 'http://git.fedorahosted.org/git?p=anaconda.git;a=blobdiff_plain;f=textw/upgrade_bootloader_text.py;h=1512b1dfdb245b41b1c09c98282f75370c6b917f;hp=db736f35c709c97cbeb4a7b4720932387031b7f7;hb=63fb1731cd77976f99b42dbf2c3598821b7faaff;hpb=fce670e62c43ff293718e63601e247de1b7dd3ea' | patch -p1
patching file textw/upgrade_bootloader_text.py
bash-3.2$ pwd
/tmp/anaconda-13.21.82
bash-3.2$ 

Please fix this for RHEL 6.2.
Comment 9 Alexander Todorov 2011-08-09 06:00:38 EDT
(In reply to comment #0)
> Steps to Reproduce:
> 1. start anaconda in text mode using upgradeany with a different bootloader
> installed in mbr


Martin,
what boot loader did you use?
Comment 10 Pavel Holica 2011-11-16 06:16:11 EST
Hello, this fix introduced new bug 754375.

There should be at least release note saying, that manual text upgrade without installed bootloader (or with different bootloader) (which is very limited scenario) doesn't have default option and one needs to select "Skip boot loader configuration".
Comment 11 David Cantrell 2011-11-22 13:13:46 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Users performing an upgrade using the text mode interface who do not have a boot loader already installed on the system or who have a non-grub boot loader will need to select "Skip Boot Loader Configuration" during installation.  Boot loader configuration will need to be completed manually after installation.  This problem does not affect users running anaconda in graphical mode (graphical mode also includes VNC connectivity mode).
Comment 12 Martin Prpic 2011-11-22 13:37:33 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Users performing an upgrade using the text mode interface who do not have a boot loader already installed on the system or who have a non-grub boot loader will need to select "Skip Boot Loader Configuration" during installation.  Boot loader configuration will need to be completed manually after installation.  This problem does not affect users running anaconda in graphical mode (graphical mode also includes VNC connectivity mode).+Users performing an upgrade using the Anaconda's text mode interface who do not have a boot loader already installed on the system, or who have a non-GRUB boot loader, need to select Skip Boot Loader Configuration during the installation process. Boot loader configuration will need to be completed manually after installation. This problem does not affect users running Anaconda in the graphical mode (graphical mode also includes VNC connectivity mode).
Comment 13 Pavel Holica 2011-11-23 03:45:08 EST
Thanks for technical note. It fully describes situation, so I'm moving this bug to verified.
Comment 14 errata-xmlrpc 2011-12-06 05:29:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1565.html

Note You need to log in before you can comment on or make changes to this bug.