Bug 67604 - Installer crashes after pressing "Next" button on disk druid after partitioning disk
Installer crashes after pressing "Next" button on disk druid after partitioni...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-27 21:28 EDT by Al Jeffcoat
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the file that was created as a result of save to floppy on the error. (38.78 KB, text/plain)
2002-06-27 21:29 EDT, Al Jeffcoat
no flags Details

  None (edit)
Description Al Jeffcoat 2002-06-27 21:28:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
After I Manually Partition my disk with disk druid, then press the next 
button, I get an "unhandled exception error.  I have atteched the resulting 
error information.  I removed my laptop from the docking station, and get the 
same error.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Select Laptop Installation
2.  Partition my system as follows: /boot=47 MB(ext3), / = 18646 MB(ext3), 384 
MB Swap.
3.  Press Next

Actual Results:  Unusual exception error

Expected Results:  I would say that it should have started a Laptop install, 
or allowed me to verify the packages.

Additional info:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 633, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/gui.py", line 353, in run
    self.icw.run (self.runres, configFileData)
  File "/usr/lib/anaconda/gui.py", line 814, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 130, in __call__
    ret = apply(self.func, a)
  File "/usr/lib/anaconda/gui.py", line 420, in nextClicked
    self.setScreen ()
  File "/usr/lib/anaconda/gui.py", line 558, in setScreen
    new_screen = apply(self.currentWindow.getScreen, args)
  File "/usr/lib/anaconda/iw/bootloader_gui.py", line 363, in getScreen
Comment 1 Al Jeffcoat 2002-06-27 21:29:35 EDT
Created attachment 62984 [details]
This is the file that was created as a result of save to floppy on the error.
Comment 2 Michael Fulbright 2002-06-28 12:20:27 EDT
Please check your CDs following these instructions:

http://people.redhat.com/~msf/mediacheck.html
Comment 3 Al Jeffcoat 2002-06-29 11:59:00 EDT
I tried that before I opened this issue ;). I have installed from the same 
media on 2 other systems (both desktops, 1 compaq, 1 custom) with no 
problems.  I also re-downloaded the iso's again, and tried installed from cd's 
made with the re-dl'ed image, and same thing.

Just an FYI, Mandrake 8.2 installs on my laptop with no problem whatsoever.
Comment 4 Jeremy Katz 2002-07-18 00:08:49 EDT
Have you actually checked the CDs with *THIS* cd drive.  Unfortunately many CD
drives (especially on laptops) seem to be very sensitive to CD-R media and these
messages imply read errors from the drive that we can't do much about.

<4>hdb: command error: status=0x51 { DriveReady SeekComplete Error }
<4>hdb: command error: error=0x54
<4>end_request: I/O error, dev 03:40 (hdb), sector 1113768


Also, does booting with 'ide=nodma' help any?
Comment 5 Al Jeffcoat 2002-07-18 00:52:00 EDT
I did try the mediacheck on this machine.  I was able to install it 1 time out 
of about 15 attempts.  When I *finally* got it to install, I was not 
satisfied, and tried about 5 more times, and could not get it to install.  It 
kept stopping at various points.  I had problems with missing packages, the 
same unusual exception error, etc.  This final straw was when I got it to the 
point where it was asking for the second cd, and when I inserted the second 
cd, it told me that it was not the second cd, and to please re-insert the 
second cd.  I gave up at that point.  And just to be clear, I used the same 
set of discs that I had re-downloaded AGAIN to install onto another machine, 
and it worked fine.  I did also test Mandrake 8.2 on this laptop, and it 
worked.  I then tried Suse 8.0, and it worked fine also, and I stuck with 
that.  I have it working very nicely now, and do not want to redo it again.  I 
would have preferred redhat, but as I cannot get it to install...  :(

Thanks for your efforts in this matter.  I'm not sure if I should close this 
issue or not.  I'll leave that up to you.
Comment 6 Jeremy Katz 2002-07-18 01:05:23 EDT
This really either sounds like a hardware problem or an incompatibility with the
kernel.  If you provide more information on the chipset in the laptop, Arjan
might  have some other idea.
Comment 7 chuck 2002-09-08 23:41:46 EDT
This describes my problem exactly. I have experienced all these symptoms. 
Are you aware that there're several other similar bug reps?
Unfortunately, I cannot get a dump to floppy (this is a fresh machine). It
shouldn't matter much as the crashes vary. The most common is the "unhandled
exception" (about 4 out of 20 times)
Here is a description of my hardware:
CPU: AMD Athlon XP 2100+ 1.6GHz
MOBO: Asus A7S333 motherboard, sis745 chipset
RAM: 512M DDR
HD: IBM 40G 7200 RPM model 07N8450
CDRW: Optirite 32x12x40x
Floppy: Sony internal 3.5" 1.44M
Video Card: NVidia TNT2 M64 AGP 32M
Monitor: CTX VL510
Modem: Blitzz I303
NIC: RealTech 10/100

Here's the first "unhandled exception", copied by hand, expect typos:
Traceback (innermost last):
 File "/usr/bin/anaconda", line 633, in ?
  intf.run(id, dispatch, configFileData)
 File "/usr/lib/anaconda/gui.py", line 353, in run
  self.icw.run (self.runres, configFileData)
 File "/usr/lib/anaconda/gui.py", line 814, in run
  mainloop ()
 File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
  _gtk.gtk_main()
 File "/usr/lib/anaconda/gui.py", line 529, in handleRenderCallback
  self.currentWindow.renderCallback()
 File "/usr/lib/anaconda/iw/progress_gui.py", line 135, in render Callback
  self.intf.icw.nextClicked
 File "/usr/lib/anaconda/gui.py", line 417, in nextClicked
  self.dispatch.gotoNext
 File "/usr/lib/anaconda/dispatch.py", line 144, in gotoNext
  self.moveStep()
 File "/usr/lib/anaconda/dispatch.py", line 209, in moveStep
  rc = apply(func, self.bindArgs(args))
 File "/usr/lib/anaconda/packages.py", line 375, in turnOnFilesystems
  thefsset.checkBadblocks(instPath)
 File "/usr/lib/anaconda/fsset.py", line 1007, in checkBadblocks
  self.badblocksEntry(entry, chroot)
 File "/usr/lib/anaconda/fsset.py", line 984, in badblocksEntry
  entry.fsystem.badblocksDevice(entry, self.progressWindow, chroot)
 File "/usr/lib/anaconda/fsset.py", line 210, in badblocksDevice
  l = string.split(num, '/')
TypeError: argument1: expected read-only character buffer, int found

I've danced around w/"support", to summarize:
1)all media fine; installed on 2 other boxes; linux mediacheck okay on 
other boxes. On Athlon, Disk3 failed 2 out of 2 times - but note that no 
install (out of >20) has ever gotten past disk 2.
2)I swapped in a ASUS 52x CDROM. Succeeded once out of 4 tries.
3)I have succeded once out of 15+ tries on the optirite; had to see if I 
could repeat; couldn't.
4)Tried "linux noathlon". Crashed.
5)Tried "linux text mem=exactmap mem=640K@0 mem=479M@1M apm=off ide=nodm"; 
Crashed after 4.5 hours(!) of disk formatting. Claimed my drive was full! 
After the format!
6)Note that video quality is horrible. Granted the CTX is way overpowered 
by the NVidia, but on one of the successes I managed to get X4 configured 
fine. Hardware probes are always correct (when the install gets that far)

I will be happy to provide further details, including CMOS. I just 
installed 6.2 successfully. I'll play w/that, then try an upgrade (I know, 
LOL)
Comment 8 Bugzilla owner 2004-09-30 11:39:43 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.