Bug 676079 - i5k_amb does not work for Intel 5000 Chipset (lm_sensors)
Summary: i5k_amb does not work for Intel 5000 Chipset (lm_sensors)
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lm_sensors   
(Show other bugs)
Version: 5.5
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Jaromír Cápík
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords:
Depends On: 603345
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-08 19:03 UTC by Dean Nelson
Modified: 2014-07-16 13:08 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 603345
Environment:
Last Closed: 2014-07-16 13:08:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dean Nelson 2011-02-08 19:03:58 UTC
+++ This bug was initially created as a clone of Bug #603345, +++
+++ in order to track the changes to lm_sensors that are      +++
+++ required to address the problem reported by that bug.     +++

Description of problem:

i5k_amb Kernel-module does not work with lm_sensors and is detected as "Driver `to-be-written' (should be inserted)" by lm_sensors. The driver is not inserted into /etc/sysconfig/lm_sensors. If loaded via modprobe sensors does not read out the sensors.

Version-Release number of selected component (if applicable):

kernel-2.6.18-194.el5.x86_64
lm_sensors-2.10.7-9.el5.x86_64

How reproducible:

every time.

Steps to Reproduce:
1. sensors-detect (confirm all questions with return)
2. sensors (no output of i5k_amb)
3. modprobe i5k_amb
4. sensors (output of i5k_amb-isa-0000 with no values)
  
Actual results:

# sensors
(...)
i5k_amb-isa-0000
Adapter: ISA adapter

#

Expected results:

# sensors|grep DIMM
Ch. 0 DIMM 0: +61.0°C (low = +74.5°C, high = +124.0°C)
Ch. 1 DIMM 0: +57.0°C (low = +74.5°C, high = +124.0°C)

Additional info:

The expected result is of a backported i5k_amb of the kernel-source and a backported lm_sensors-3.0.2-1 of Fedora 10, backports of both done by me.

backported i5k_amb:

# modinfo /lib/modules/2.6.18-164.el5/weak-updates/i5k_amb.ko
filename:       /lib/modules/2.6.18-164.el5/weak-updates/i5k_amb.ko
license:        GPL
description:    Intel 5000 chipset FB-DIMM AMB temperature sensor
author:         Darrick J. Wong <djwong@us.ibm.com>
srcversion:     F0146D28050A139EA3F5217
depends:        hwmon
vermagic:       2.6.18-128.1.6.el5 SMP mod_unload gcc-4.1

i5k_amb of release:

# modinfo /lib/modules/2.6.18-194.el5/kernel/drivers/hwmon/i5k_amb.ko
filename:       /lib/modules/2.6.18-194.el5/kernel/drivers/hwmon/i5k_amb.ko
license:        GPL
description:    Intel 5000 chipset FB-DIMM AMB temperature sensor
author:         Darrick J. Wong <djwong@us.ibm.com>
srcversion:     4BD7A9BD6128E807E21424B
depends:        hwmon
vermagic:       2.6.18-194.el5 SMP mod_unload gcc-4.1
module_sig:    
883f3504bb644ffc596239a507de7fd112fd009e2081a1225fc9e661165b83fa8e7244b9338a63409e34e14f61f5541119674625715379e30b4677fda

--- Additional comment from gerrit.slomma@itsslomma.de on 2010-06-12 10:01:02 EDT ---

Seems to be a problem of lm_sensors, rebased.

lspci of system as follows

# lspci
00:00.0 Host bridge: Intel Corporation 5000V Chipset Memory Controller Hub (rev b1)
00:02.0 PCI bridge: Intel Corporation 5000 Series Chipset PCI Express x8 Port 2-3 (rev b1)
00:03.0 PCI bridge: Intel Corporation 5000 Series Chipset PCI Express x4 Port 3 (rev b1)
00:08.0 System peripheral: Intel Corporation 5000 Series Chipset DMA Engine (rev b1)
00:10.0 Host bridge: Intel Corporation 5000 Series Chipset FSB Registers (rev b1)
00:10.1 Host bridge: Intel Corporation 5000 Series Chipset FSB Registers (rev b1)
00:10.2 Host bridge: Intel Corporation 5000 Series Chipset FSB Registers (rev b1)
00:11.0 Host bridge: Intel Corporation 5000 Series Chipset Reserved Registers (rev b1)
00:13.0 Host bridge: Intel Corporation 5000 Series Chipset Reserved Registers (rev b1)
00:15.0 Host bridge: Intel Corporation 5000 Series Chipset FBD Registers (rev b1)
00:16.0 Host bridge: Intel Corporation 5000 Series Chipset FBD Registers (rev b1)
00:1c.0 PCI bridge: Intel Corporation 631xESB/632xESB/3100 Chipset PCI Express Root Port 1 (rev 09)
00:1d.0 USB Controller: Intel Corporation 631xESB/632xESB/3100 Chipset UHCI USB Controller #1 (rev 09)
00:1d.1 USB Controller: Intel Corporation 631xESB/632xESB/3100 Chipset UHCI USB Controller #2 (rev 09)
00:1d.2 USB Controller: Intel Corporation 631xESB/632xESB/3100 Chipset UHCI USB Controller #3 (rev 09)
00:1d.3 USB Controller: Intel Corporation 631xESB/632xESB/3100 Chipset UHCI USB Controller #4 (rev 09)
00:1d.7 USB Controller: Intel Corporation 631xESB/632xESB/3100 Chipset EHCI USB2 Controller (rev 09)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d9)
00:1f.0 ISA bridge: Intel Corporation 631xESB/632xESB/3100 Chipset LPC Interface Controller (rev 09)
00:1f.1 IDE interface: Intel Corporation 631xESB/632xESB IDE Controller (rev 09)
00:1f.2 SATA controller: Intel Corporation 631xESB/632xESB SATA AHCI Controller (rev 09)
00:1f.3 SMBus: Intel Corporation 631xESB/632xESB/3100 Chipset SMBus Controller (rev 09)
01:00.0 PCI bridge: Intel Corporation 6311ESB/6321ESB PCI Express Upstream Port (rev 01)
01:00.3 PCI bridge: Intel Corporation 6311ESB/6321ESB PCI Express to PCI-X Bridge (rev 01)
02:00.0 PCI bridge: Intel Corporation 6311ESB/6321ESB PCI Express Downstream Port E1 (rev 01)
02:02.0 PCI bridge: Intel Corporation 6311ESB/6321ESB PCI Express Downstream Port E3 (rev 01)
04:00.0 Ethernet controller: Intel Corporation 80003ES2LAN Gigabit Ethernet Controller (Copper) (rev 01)
04:00.1 Ethernet controller: Intel Corporation 80003ES2LAN Gigabit Ethernet Controller (Copper) (rev 01)
08:02.0 VGA compatible controller: XGI Technology Inc. (eXtreme Graphics Innovation) Z7/Z9 (XG20 core)

--- Additional comment from gerrit.slomma@itsslomma.de on 2010-10-06 10:43:12 EDT ---

Sorry for the delay, i must have missed the notification.
But what does /proc/cpuinfo has to do with this?

--- Additional comment from npajkovs@redhat.com on 2010-10-07 08:03:01 EDT ---

Created attachment 452092 [details]
patched sensors-detect

Sorry, I was thinking that you are talking about cpu. Nevertheless, try this sensors-detect. Seems that everything is ok, but needs to be removed *to-be-written* and put there i5k_amb.

Feedback welcome.

--- Additional comment from gerrit.slomma@itsslomma.de on 2010-10-07 14:29:05 EDT ---

No as stated in my initial post: sensors-detect detects "to-be-written" and does not insert the i5k_amb into /etc/sysconfig/lm_sensors hence the module is not loaded it lm_sensors ist started. If i5k_amb is modprobed by hand i get
i5k_amb-isa-0000
Adapter: ISA adapter
but no values are printed.
My own built module works without problems.
The module from rhel6b work without problems too.

# sensors
i5k_amb-isa-0000
Adapter: ISA adapter
Ch. 0 DIMM 0: +53.0°C  (low  = +74.5°C, high = +124.0°C)
Ch. 1 DIMM 0: +48.5°C  (low  = +74.5°C, high = +124.0°C)

(however it is loaded by default no idea why...)

--- Additional comment from gerrit.slomma@itsslomma.de on 2010-10-07 14:29:37 EDT ---

the module from rhel6b in rhel6b to be a tad bit more specific...

--- Additional comment from pm-rhel@redhat.com on 2011-01-11 15:15:37 EST ---

This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

--- Additional comment from pm-rhel@redhat.com on 2011-01-11 18:00:29 EST ---

This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

--- Additional comment from kai2+redhat@schaetzl.de on 2011-01-25 09:04:50 EST ---

What does "current release" mean? Is this to be included in the next errata upgrade for the current 5.6 kernel?

--- Additional comment from jarod@redhat.com on 2011-01-26 11:44:39 EST ---

(In reply to comment #13)
> What does "current release" mean? Is this to be included in the next errata
> upgrade for the current 5.6 kernel?

This bug is currently under consideration for being fixed in 5.7, but note that this bug is against lm_sensors, not the kernel. Based on comment #9 though, it looks like this bug should be changed to the kernel component, so I'm moving it there. Once fixed in 5.7, it *can* be proposed for inclusion in a 5.6 errata kernel as well.

--- Additional comment from jarod@redhat.com on 2011-01-26 11:46:03 EST ---

Setting state back to NEW, as I believe this bug needs to be assigned to a kernel engineer here. Prarit, do you know who the appropriate assignee would be on this?

--- Additional comment from prarit@redhat.com on 2011-01-26 13:22:10 EST ---

(In reply to comment #15)
> Setting state back to NEW, as I believe this bug needs to be assigned to a
> kernel engineer here. Prarit, do you know who the appropriate assignee would be
> on this?

Assigning to dnelson.

P.

--- Additional comment from dnelson@redhat.com on 2011-02-08 13:49:38 EST ---

Component-wise, there are really two separate issues here.

This bug will be used to track the kernel refresh of drivers/hwmon/i5k_amb.c, to make it as much like upstream as RHEL5 will allow.

And I'll clone a new bug to track the refresh of lm_sensors to something that works. RHEL5 has version 2.10.7 and doesn't work. RHEL6 has version 3.1.1 and does work.

Comment 1 RHEL Product and Program Management 2014-03-07 13:56:26 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 2 Dean Nelson 2014-03-07 16:06:22 UTC
(In reply to RHEL Product and Program Management from comment #1)
> last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at
> the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your

It would have been nice if lm_sensors could have been refreshed in RHEL5, but at this point I see that as unlikely and the imminent closure of this BZ as inevitable. So be it.

Comment 3 Ondrej Vasik 2014-07-16 13:08:26 UTC
Ok, thanks. Closing WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.