Bug 676165 - Typo in multipath output, "mulipath.conf line 17, invalid keyword:"
Typo in multipath output, "mulipath.conf line 17, invalid keyword:"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
5.6
All Linux
medium Severity medium
: rc
: ---
Assigned To: Ben Marzinski
Jiajian Yang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-08 18:27 EST by Ben Turner
Modified: 2011-08-16 08:59 EDT (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-21 04:22:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch that fixes typo (456 bytes, patch)
2011-02-08 18:30 EST, Ben Turner
no flags Details | Diff

  None (edit)
Description Ben Turner 2011-02-08 18:27:41 EST
Description of problem:

There is a typo in the new multipath package:

[root@cs-rh5-1 /]# multipath
mulipath.conf line 17, invalid keyword: polling_interval

I wrote a quick patch to fix it.

Version-Release number of selected component (if applicable):

[root@cs-rh5-1 /]# rpm -q device-mapper-multipath
device-mapper-multipath-0.4.7-42

How reproducible:

Easily reproducible.

Steps to Reproduce:
1.  Run the command multiapth with an error in the config file
2.  Look at console output and messages file
3.
  
Actual results:

Multipath.conf is spelled wrong.

Expected results:

Multipath.conf is spelled correct.

Additional info:

Attached a patch that should fix it.
Comment 1 Ben Turner 2011-02-08 18:30:00 EST
Created attachment 477713 [details]
Patch that fixes typo

Patch that fixes typo
Comment 2 Ben Marzinski 2011-03-07 00:22:40 EST
Patch applied. Thanks.
Comment 3 larry creasy 2011-04-07 12:21:23 EDT
how the heck do you patch this?  what are you actually patching?
Any help would be most appreciated!
thank you!!!
Comment 4 Ben Marzinski 2011-04-07 14:57:33 EDT
Commont #1 has the patch, I'm patching the device-mapper-multipath source

It's available for web-viewing here:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/multipath-tools/?cvsroot=dm

and can be checked out via cvs with

cvs -d :pserver:cvs@sources.redhat.com:/cvs/dm login cvs
cvs -d :pserver:cvs@sources.redhat.com:/cvs/dm checkout multipath-tools
The password is cvs.

This is a trivial fix for a spelling mistake.
Comment 5 larry creasy 2011-04-07 16:27:41 EDT
kewl, thank you,
so do I just replace the directories? do I create a rpm package?
not sure where to go from here.
Comment 6 Ben Marzinski 2011-04-07 22:40:31 EDT
I'm confused as to why you want to build your own version of device-mapper-multipath with this fix.  All this does is fix a typo in one error message.

Instead of printing

mulipath.conf line <LINE_NR>, invalid keyword:

it will now print

multipath.conf line <LINE_NR>, invalid keyword:

The easiest way to patch this is to get the src.rpm you want, apply the patch to that, and rebuild the rpm.

The other way is to run

# cvs -d :pserver:cvs@sources.redhat.com:/cvs/dm login cvs

The password is "cvs"

# cvs -d :pserver:cvs@sources.redhat.com:/cvs/dm checkout -r RHEL5_FC6 multipath-tools

This will checkout the latest multipath.conf source.  Assuming you have all of the development libraries, you can build this, and it already includes this patch. If you want to continue using your existing multipath code with simply this package added, you need to look at the src.rpm for it, figure out the proper cvs tag, checkout that version, manually apply the patch and rebuild.

But, like I said, that's a lot of work to simply change "mulipath" to "multipath" in one error message.
Comment 10 errata-xmlrpc 2011-07-21 04:22:55 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1032.html
Comment 11 Oren Held 2011-08-16 08:59:34 EDT
Just a small note for those who got here because of the "polling_interval" problem (as opposed to the typo problem which this ticket handles) -
Starting on RHEL 5.6 (due to #560892 fix or 75d588b92f6 git hash), multipath.conf processing started reporting conf file errors.

So in cases such as putting the polling_interval configuration directive in the wrong place (e.g. inside "devices" section, whereas it belongs to the "defaults" section), this error is reported.

Before RHEL5.6 the problem was silently skipped.

Note You need to log in before you can comment on or make changes to this bug.