Bug 676193 - debuginfo-install fails to find debuginfo packages
Summary: debuginfo-install fails to find debuginfo packages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum-utils
Version: 6.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: James Antill
QA Contact: Karel Srot
URL:
Whiteboard:
: 827001 (view as bug list)
Depends On:
Blocks: 782183 1056252
TreeView+ depends on / blocked
 
Reported: 2011-02-09 02:32 UTC by Anthony Symons
Modified: 2018-12-09 16:43 UTC (History)
13 users (show)

Fixed In Version: yum-utils-1.1.30-19.el6
Doc Type: Bug Fix
Doc Text:
Previously, debuginfo-install considered only certain naming scheme of debuginfo repositories, which Certificate-based Red Hat Network content delivery network (CDN) did not follow. As a consequence, the debuginfo-install utility did not work with the debuginfo repositories created in CDN. With this update, support for the new naming scheme of debuginfo repositories has been added, and debuginfo-install now works with debuginfo CDN repositories as intended.
Clone Of:
Environment:
Last Closed: 2014-10-14 04:37:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1411 normal SHIPPED_LIVE yum-utils bug fix update 2014-10-14 00:54:50 UTC

Description Anthony Symons 2011-02-09 02:32:51 UTC
Description of problem:

When trying to test compile a project, ld segfaulted and core dumped. When trying to get a backtrace to report the bug, gdb told me 

"Missing separate debuginfos, use: debuginfo-install binutils-2.20.51.0.2-5.11.el6.x86_64"

When trying to run that command:

[root@localhost apilib]# debuginfo-install binutils-2.20.51.0.2-5.11.el6.x86_64
Loaded plugins: auto-update-debuginfo, rhnplugin
enabling epel-debuginfo
Reading repository metadata in from local files
Could not find debuginfo for main pkg: binutils-2.20.51.0.2-5.11.el6.x86_64
Could not find debuginfo pkg for dependency package binutils-2.20.51.0.2-5.11.el6.x86_64
Could not find debuginfo pkg for dependency package glibc-2.12-1.7.el6_0.3.x86_64
Could not find debuginfo pkg for dependency package glibc-2.12-1.7.el6_0.3.x86_64
Could not find debuginfo pkg for dependency package glibc-2.12-1.7.el6_0.3.x86_64
Could not find debuginfo pkg for dependency package glibc-2.12-1.7.el6_0.3.x86_64
Could not find debuginfo pkg for dependency package glibc-2.12-1.7.el6_0.3.x86_64
Could not find debuginfo pkg for dependency package glibc-2.12-1.7.el6_0.3.x86_64
Could not find debuginfo pkg for dependency package glibc-2.12-1.7.el6_0.3.x86_64
Could not find debuginfo pkg for dependency package glibc-2.12-1.7.el6_0.3.x86_64
Could not find debuginfo pkg for dependency package binutils-2.20.51.0.2-5.11.el6.x86_64
Could not find debuginfo pkg for dependency package zlib-1.2.3-25.el6.x86_64
No debuginfo packages available to install

Version-Release number of selected component (if applicable):

yum-utils-1.1.26-11.el6.noarch

How reproducible:

just run "
debuginfo-install binutils-2.20.51.0.2-5.11.el6.x86_64"

Steps to Reproduce:
1. run "debuginfo-install binutils-2.20.51.0.2-5.11.el6.x86_64"
2.
3.
  
Actual results:

Fails to find any debug info. 

Expected results:

Debug info to install. 

Additional info:

This system is registered on RHN and is up to date.

Comment 2 RHEL Product and Program Management 2011-04-04 02:11:08 UTC
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 3 Phil Knirsch 2011-07-19 18:44:24 UTC
For RHEL-6 this was changed a bit that in order to install debuginfo packages you need to subscribe to the related channel in RHN:

RHEL Server Debuginfo (v.6 for x86_64)

A request to update the documentation to reflect this has been opened:

https://bugzilla.redhat.com/show_bug.cgi?id=723322

Thanks & regards, Phil

Comment 4 Frank Ch. Eigler 2012-08-15 21:04:42 UTC
This is IMO inadequate.  If debuginfo-install can activate the -debuginfo channel, it should.  If debuginfo-install can tell that the -debuginfo channel is not subscribed-to, but should be, then it should say so.

Comment 5 Mark Wielaard 2012-08-16 10:52:42 UTC
This is also an issue for other components, like systemtap, that advise users to use debuginfo-install to get better introspection into their system.

Comment 7 Jiri Moskovcak 2013-03-15 14:34:33 UTC
The problem is that the debuginfo repositories in rhel6 doesn't have "debuginfo" in their name, but only debug. This seems like a dupe of #617162 which has been closed as NOTABUG. Please either fix the tool or reassign this to someone who is responsible for naming the repositories:

RHN repos available on my machine:
rhel-ha-for-rhel-6-server-beta-debug-rpms
rhel-6-server-rhev-agent-beta-debug-rpms
rhel-6-server-cf-tools-1-debug-rpms
rhel-6-server-debug-rpms
rhel-6-server-optional-beta-debug-rpms
rhel-6-server-supplementary-debuginfo
rhel-6-server-sam-debug-rpms
rhel-6-server-sam-beta-debug-rpms
rhel-lb-for-rhel-6-server-beta-debug-rpms
rhel-6-server-supplementary-beta-debuginfo
rhel-rs-for-rhel-6-server-beta-debug-rpms
rhel-lb-for-rhel-6-server-debug-rpms
rhel-6-server-beta-debug-rpms
rhel-6-server-optional-debug-rpms
rhel-6-server-rhev-agent-debug-rpms
rhel-6-server-cf-tools-1-beta-debug-rpms
rhel-rs-for-rhel-6-server-debug-rpms
rhel-ha-for-rhel-6-server-debug-rpms

possible dupes #827001 #730249 #828871

Comment 8 James Antill 2013-04-12 20:04:10 UTC
*** Bug 827001 has been marked as a duplicate of this bug. ***

Comment 9 James Antill 2013-04-12 20:05:20 UTC
I've ACKd this, as we can put the same hack in that we did for the similar -src-rpms mess ... it won't be pretty, but at least it'll work at that point.

Comment 17 RHEL Product and Program Management 2013-10-14 01:10:47 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 19 Frank Ch. Eigler 2014-01-14 16:39:17 UTC
See also bug #1052871, apprx. same issue for RHEL7.

Comment 25 errata-xmlrpc 2014-10-14 04:37:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1411.html


Note You need to log in before you can comment on or make changes to this bug.