Bug 676226 - (CVE-2011-0558, CVE-2011-0559, CVE-2011-0560, CVE-2011-0561, CVE-2011-0571, CVE-2011-0572, CVE-2011-0573, CVE-2011-0574, CVE-2011-0575, CVE-2011-0577, CVE-2011-0578, CVE-2011-0607, CVE-2011-0608) CVE-2011-0558 CVE-2011-0559 CVE-2011-0560 CVE-2011-0561 CVE-2011-0571 CVE-2011-0572 CVE-2011-0573 CVE-2011-0574 CVE-2011-0575 CVE-2011-0577 CVE-2011-0578 CVE-2011-0607 CVE-2011-0608 flash-plugin: multiple code execution flaws (APSB11-02)
CVE-2011-0558 CVE-2011-0559 CVE-2011-0560 CVE-2011-0561 CVE-2011-0571 CVE-201...
Status: CLOSED ERRATA
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Red Hat Product Security
public=20110208,reported=20110208,sou...
: Security
Depends On: 676227 676228 676229 685072
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-09 01:01 EST by Vincent Danen
Modified: 2015-08-19 05:05 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 11:49:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vincent Danen 2011-02-09 01:01:43 EST
Adobe security bulletin APSB11-02 describes multiple security flaws that can lead to arbitrary code execution when a malicious flash file is opened by Adobe Flash Player.

http://www.adobe.com/support/security/bulletins/apsb11-02.html

This update resolves an integer overflow vulnerability that could lead to code execution (CVE-2011-0558).

This update resolves a memory corruption vulnerability that could lead to code execution (CVE-2011-0559).

This update resolves a memory corruption vulnerability that could lead to code execution (CVE-2011-0560, CVE-2011-0561).

This update resolves multiple memory corruption vulnerabilities that could lead to code execution (CVE-2011-0571, CVE-2011-0572, CVE-2011-0573, CVE-2011-0574).

This update resolves a library-loading vulnerability that could lead to code execution (CVE-2011-0575).

This update resolves a font-parsing vulnerability that could lead to code execution (CVE-2011-0577).

This update resolves a memory corruption vulnerability that could lead to code execution (CVE-2011-0578).

This update resolves a memory corruption vulnerability that could lead to code execution (CVE-2011-0607).

This update resolves a memory corruption vulnerability that could lead to code execution (CVE-2011-0608).


These flaws were corrected in Adobe Flash Plugin 10.2.152.26.
Comment 3 errata-xmlrpc 2011-02-09 12:57:52 EST
This issue has been addressed in following products:

  Extras for Red Hat Enterprise Linux 5
  Extras for Red Hat Enterprise Linux 6

Via RHSA-2011:0206 https://rhn.redhat.com/errata/RHSA-2011-0206.html
Comment 4 errata-xmlrpc 2011-02-15 14:33:18 EST
This issue has been addressed in following products:

  Extras for RHEL 4

Via RHSA-2011:0259 https://rhn.redhat.com/errata/RHSA-2011-0259.html
Comment 6 errata-xmlrpc 2011-03-21 12:31:40 EDT
This issue has been addressed in following products:

  Extras for RHEL 4

Via RHSA-2011:0368 https://rhn.redhat.com/errata/RHSA-2011-0368.html

Note You need to log in before you can comment on or make changes to this bug.