Bug 676253 - [abattis-cantarell-fonts] causes tiny characters of desktop fonts
Summary: [abattis-cantarell-fonts] causes tiny characters of desktop fonts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abattis-cantarell-fonts
Version: 15
Hardware: noarch
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Cosimo Cecchi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 677865 (view as bug list)
Depends On:
Blocks: F15Blocker-kde
TreeView+ depends on / blocked
 
Reported: 2011-02-09 08:33 UTC by Joachim Frieben
Modified: 2018-04-11 17:20 UTC (History)
10 users (show)

Fixed In Version: abattis-cantarell-fonts-0.0.4-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-10 03:15:54 UTC


Attachments (Terms of Use)
Screenshot of GNOME terminal when package abattis-cantarell-fonts is installed (15.08 KB, image/png)
2011-02-09 08:33 UTC, Joachim Frieben
no flags Details
Comparison of "Sans 10" and "Cantarell" fonts (106.67 KB, image/png)
2011-02-14 09:54 UTC, Joachim Frieben
no flags Details
Screenshot of GNOME shell with abattis-cantarell-fonts-0.0.1-4.fc15 (620.20 KB, image/png)
2011-02-19 07:14 UTC, Joachim Frieben
no flags Details
for better fontconfig config file (768 bytes, patch)
2011-03-08 08:27 UTC, Akira TAGOH
no flags Details | Diff

Description Joachim Frieben 2011-02-09 08:33:10 UTC
Created attachment 477766 [details]
Screenshot of GNOME terminal when package abattis-cantarell-fonts is installed

Description of problem:
The upgrade to gnome-themes-standard-2.91.8-4.fc15 pulls in package abattis-cantarell-fonts-0.0.1-2.fc15. After launching a new GNOME session, button labels and all other places where abattis-cantarell has been substituted for the previous standard desktop fonts exhbit tiny font sizes making text difficult to read apart from the weird appearance.

Version-Release number of selected component (if applicable):
abattis-cantarell-fonts-0.0.1-2.fc15.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Upgrade to gnome-themes-standard-2.91.8-4.fc15.
2. Start a new GNOME session.
  
Actual results:
Text labels, e.g. of the GNOME shell are ridiculously tiny.

Expected results:
Text labels have a reasonable size as before.

Additional info:
Removing package abattis-cantarell-fonts from the system restores resonable font sizes.

Comment 1 Matthias Clasen 2011-02-11 22:58:17 UTC
The fonts in your screenshot don't look 'ridiculously small' to me.
Anyway, the next set of release will move the font out of the theme css and into
settings, then you can just do

gsettings set org.gnome.desktop.interface font-name 'Sans 10' to get your old fonts back.

Comment 2 Joachim Frieben 2011-02-14 09:54:34 UTC
Created attachment 478596 [details]
Comparison of "Sans 10" and "Cantarell" fonts

Unfortunately, the command given in comment 1, namely

  gsettings set org.gnome.desktop.interface font-name 'Sans 10'

does not revert to the previous font family (I suppose the sans font family has been mapped to the Cantarell one). The command actually works because

  gsettings set org.gnome.desktop.interface font-name 'Sans 11'

does provide a -larger- Cantarell font, but the font family just stays the same.
If you look at the attached screenshot you will notice that a font size of 10 differs significantly for the previous sans serif font and the Cantarell one. This is of course not forbidden but from the ergonomic point of view the difference is noteworthy and I wonder whether this change was a deliberate one.

Comment 3 Cosimo Cecchi 2011-02-14 14:24:14 UTC
(In reply to comment #2)
> Created attachment 478596 [details]
> Comparison of "Sans 10" and "Cantarell" fonts
> 
> Unfortunately, the command given in comment 1, namely
> 
>   gsettings set org.gnome.desktop.interface font-name 'Sans 10'
> 
> does not revert to the previous font family (I suppose the sans font family has
> been mapped to the Cantarell one).

If you carefully read Matthias' comment, it says "the next set of release will move the font out of the theme css and into settings", which means this is only supported in git master upstream, and not in the Fedora GNOME packages, that will be updated probably next week along with the new GNOME development release.

Comment 4 Cosimo Cecchi 2011-02-14 14:26:36 UTC
Oh, if you really can't wait, you should be able to change font temporarily by hand-editing /usr/share/themes/Adwaita/gtk-3.0/gtk.css and change the line "font: Cantarell;" to something else.

Comment 5 Joachim Frieben 2011-02-14 16:04:36 UTC
(In reply to comment #4)
Thanks, I roughly know how to tweak my own user interface. My concern is about the default settings a fresh F15 user account is going to deal with. I do find the current font preferences suboptimal.

Comment 6 Dennis Gilmore 2011-02-16 14:16:27 UTC
Id like to note that the new font has broken things horribly for me. it seems to be lacking completely in unicode support.  at the least i dont get unicode characters showing. i get a pair of ?? instead. i actually tested it in konsole, Terminal and gnome-terminal.

Comment 7 Akira TAGOH 2011-02-17 09:37:10 UTC
I saw same issue here.

This is because of the bad alphabetical ordering in the fontconfig config files with the priority. you can see 57-cantarell.conf appears prior to 57-dejavu-*.conf.  Howerver there are nothing wrong in current packaging guidelines. that says "55-59  High priority LGC (latin Greek Cyrillic) fonts (distribution general-purpose default fonts" so that would be a kind of the pit in the guidelines IMHO. that should be more strict.

For workaround, giving higher priority to dejavu would makes more sense.

Comment 8 Nicolas Mailhot 2011-02-17 11:08:43 UTC
fontconfig should fallback to dejavu if cantarell is missing some glyphs.

Now, there are many reasons why it may not work :
1. someone decided to install cantarell, without installing dejavu (nothing to fallback to)
2. some software stacks may forcibly disable fontconfig fallback (web people like to do this because they prefer CSS fallback to system fallback – except CSS rules for i18n are usually junk)
3. cantarell declares it includes glyphs but does not really (this may cause ?? symbols) → a bug in the fonts

Anyway, I think the current packaging guidelines are fine, but art people need to learn that High priority LGC (latin Greek Cyrillic) fonts mean fonts with decent Latin Greek Cyrillic coverage and not just ASCII fonts. If that's not clear enough, change the guidelines to forbid fonts that do not provide at least mes-2 or mes-3 coverage to appear above 59 priority in sans (serif and mono are less critical)

http://www.evertype.com/standards/iso10646/pdf/cwa13873.pdf

Comment 9 Akira TAGOH 2011-02-17 11:32:06 UTC
I'm pointing out that there are no explicit explanation how to meet the priority between 55 and 59 in this case if the font meets the enough coverage for high priority LGC fonts. and why does DejaVu not have 55 but 57. I could guess some reason, but no explanations for that in the guidelines at all. that should has a chance to be improved further more.

Comment 10 Nicolas Mailhot 2011-02-17 12:53:00 UTC
The explanation for that is simple, so far there has been a wish to priorize liberation, dejavu and droid so they took the 59, 58 and 57 slots

If cantarell should be priorized too it may need some shuffling

I'm not sure it's ok to make cantarell a high priority font if it's missing many glyphs

Comment 11 Fedora Update System 2011-02-18 22:43:02 UTC
abattis-cantarell-fonts-0.0.1-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abattis-cantarell-fonts-0.0.1-4.fc15

Comment 12 Fedora Update System 2011-02-19 02:50:54 UTC
abattis-cantarell-fonts-0.0.1-4.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update abattis-cantarell-fonts'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/abattis-cantarell-fonts-0.0.1-4.fc15

Comment 13 Joachim Frieben 2011-02-19 07:14:51 UTC
Created attachment 479647 [details]
Screenshot of GNOME shell with abattis-cantarell-fonts-0.0.1-4.fc15

Desktop applications are using the previous (larger) default font now. Labels in the GNOME shell, however, are barely readable due to the tiny characters of the Cantarell font.

Comment 14 Joachim Frieben 2011-03-07 15:44:30 UTC
Package abattis-cantarell-fonts-0.0.3-1.fc15 provides a satisfactory user experience.

Comment 15 Fedora Update System 2011-03-07 23:39:59 UTC
abattis-cantarell-fonts-0.0.4-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abattis-cantarell-fonts-0.0.4-1.fc15

Comment 16 Akira TAGOH 2011-03-08 08:27:55 UTC
Created attachment 482852 [details]
for better fontconfig config file

Reviewed the fontconfig config file in abattis-cantarell-fonts. it doesn't take any effects and not following up our guidelines at all. I've attached a proposed patch to make it better. and you also need to rename it to 60-cantarell.conf at least or 61-, 62-, 63- or 64- as needed. see http://fedoraproject.org/wiki/Fontconfig_packaging_tips for more details.

Comment 17 Akira TAGOH 2011-03-08 08:29:23 UTC
also please don't miss the same change in rawhide branch too.

Comment 18 Fedora Update System 2011-03-10 03:15:48 UTC
abattis-cantarell-fonts-0.0.4-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Cosimo Cecchi 2011-04-07 13:34:45 UTC
*** Bug 677865 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.