Bug 676316 - NM crashes on every shutdown: dbus_g_proxy_new_for_name: assertion `connection != NULL' failed
Summary: NM crashes on every shutdown: dbus_g_proxy_new_for_name: assertion `connectio...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 673816 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-09 13:54 UTC by Tomasz Torcz
Modified: 2011-04-12 21:27 UTC (History)
2 users (show)

Fixed In Version: NetworkManager-0.8.3.996-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-02 01:50:23 UTC


Attachments (Terms of Use)

Description Tomasz Torcz 2011-02-09 13:54:47 UTC
Version-Release number of selected component (if applicable):
0.8.2-6.git20101117.fc15

How reproducible:
Everytime I shutdown my computer there's a backtrace from NM saved in logs.

Steps to Reproduce:
1. poweroff
2.
3.
  

Additional info:
NetworkManager[980]: <warn> disconnected by the system bus.
NetworkManager[980]: <info> caught signal 15, shutting down normally.
NetworkManager[980]: <info> Updating /etc/hosts with new system hostname
NetworkManager[980]: dbus_g_proxy_new_for_name: assertion `connection != NULL' failed
NetworkManager[980]: <error> [1297258900.341143] [NetworkManagerUtils.c:399] nm_utils_call_dispatcher(): could not get dispatcher proxy!
NetworkManager[980]: <warn> caught signal 6. Generating backtrace...
NetworkManager: ******************* START **********************************
NetworkManager: [Thread debugging using libthread_db enabled]
NetworkManager: [New Thread 0x7f339126f700 (LWP 1108)]
NetworkManager: [New Thread 0x7f3391c90700 (LWP 1063)]
NetworkManager: 0x00007f33928e80bd in __libc_waitpid (pid=<optimized out>, stat_loc=<optimized out>, options=<optimized out>) at ../sysdeps/unix/sysv/linux/waitpid.c:41
NetworkManager: 41#011  int result = INLINE_SYSCALL (wait4, 4, pid, stat_loc, options, NULL);
NetworkManager: #0  0x00007f33928e80bd in __libc_waitpid (pid=<optimized out>, stat_loc=<optimized out>, options=<optimized out>) at ../sysdeps/unix/sysv/linux/waitpid.c:41
NetworkManager: #1  0x0000000000459ed3 in nm_logging_backtrace ()
NetworkManager: #2  0x0000000000441179 in ?? ()
NetworkManager: #3  <signal handler called>
NetworkManager: #4  0x00007f3391ee2285 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
NetworkManager: #5  0x00007f3391ee3b9b in abort () at abort.c:92
NetworkManager: #6  0x0000003f9ec66c0d in g_assertion_message (domain=<optimized out>, file=<optimized out>, line=<optimized out>, func=0x4929d0 "dispose", message=0xc48d20 "assertion failed: (bus)") at gtestutils.c:1358
NetworkManager: #7  0x0000003f9ec67132 in g_assertion_message_expr (domain=0x0, file=0x49036a "nm-manager.c", line=4354, func=0x4929d0 "dispose", expr=<optimized out>) at gtestutils.c:1369
NetworkManager: #8  0x0000000000451a7c in ?? ()
NetworkManager: #9  0x0000003f9f80f833 in g_object_unref (_object=0xc50030) at gobject.c:2697
NetworkManager: #10 0x000000000041c590 in main ()
NetworkManager: 
NetworkManager: Thread 3 (Thread 0x7f3391c90700 (LWP 1063)):
NetworkManager: #0  0x00007f3391f834b3 in __poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
NetworkManager:         resultvar = <optimized out>
NetworkManager: 
NetworkManager:         result = <optimized out>
NetworkManager: #1  0x0000003f9ec430b4 in g_main_context_poll (n_fds=1, fds=0x7f338c001150, timeout=-1, context=0xc603e0, priority=<optimized out>) at gmain.c:3404
NetworkManager:         poll_func = 0x3f9ec51770 <g_poll>
NetworkManager: #2  g_main_context_iterate (context=0xc603e0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3086
NetworkManager: 
NetworkManager: 
NetworkManager:         some_ready = <optimized out>
NetworkManager: 
NetworkManager:         allocated_nfds = <optimized out>
NetworkManager:         fds = 0x7f338c001150
NetworkManager: #3  0x0000003f9ec4399a in g_main_loop_run (loop=0xc603c0) at gmain.c:3299
NetworkManager: 
NetworkManager: #4  0x0000003fa00bd4a4 in gdbus_shared_thread_func (data=<optimized out>) at gdbusprivate.c:276
NetworkManager: No locals.
NetworkManager: #5  0x0000003f9ec689b4 in g_thread_create_proxy (data=0xc604c0) at gthread.c:1897
NetworkManager:         thread = 0xc604c0
NetworkManager: 
NetworkManager: #6  0x00007f33928e0d0b in start_thread (arg=0x7f3391c90700) at pthread_create.c:301
NetworkManager:         __res = <optimized out>
NetworkManager:         pd = 0x7f3391c90700
NetworkManager:         now = <optimized out>
NetworkManager: 
NetworkManager: 
NetworkManager:         pagesize_m1 = <optimized out>
NetworkManager:         sp = <optimized out>
NetworkManager:         freesize = <optimized out>
NetworkManager: 
NetworkManager: #7  0x00007f3391f8bd3d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115
NetworkManager: No locals.
NetworkManager: 
NetworkManager: Thread 2 (Thread 0x7f339126f700 (LWP 1108)):
NetworkManager: #0  0x00007f33928e760d in read () at ../sysdeps/unix/syscall-template.S:82
NetworkManager: No locals.
NetworkManager: #1  0x0000003f9ec44a0b in read (__nbytes=20, __buf=0x7f339126ed50, __fd=<optimized out>) at /usr/include/bits/unistd.h:45
NetworkManager: No locals.
NetworkManager: #2  child_watch_helper_thread (data=<optimized out>) at gmain.c:4293
NetworkManager: 
NetworkManager:         list = <optimized out>
NetworkManager: #3  0x0000003f9ec689b4 in g_thread_create_proxy (data=0xc6a030) at gthread.c:1897
NetworkManager:         thread = 0xc6a030
NetworkManager: 
NetworkManager: #4  0x00007f33928e0d0b in start_thread (arg=0x7f339126f700) at pthread_create.c:301
NetworkManager:         __res = <optimized out>
NetworkManager:         pd = 0x7f339126f700
NetworkManager:         now = <optimized out>
NetworkManager: 
NetworkManager: 
NetworkManager:         pagesize_m1 = <optimized out>
NetworkManager:         sp = <optimized out>
NetworkManager:         freesize = <optimized out>
NetworkManager: 
NetworkManager: #5  0x00007f3391f8bd3d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115
NetworkManager: No locals.
NetworkManager: 
NetworkManager: Thread 1 (Thread 0x7f3392cee820 (LWP 980)):
NetworkManager: #0  0x00007f33928e80bd in __libc_waitpid (pid=<optimized out>, stat_loc=<optimized out>, options=<optimized out>) at ../sysdeps/unix/sysv/linux/waitpid.c:41
NetworkManager:         resultvar = <optimized out>
NetworkManager: 
NetworkManager:         result = <optimized out>
NetworkManager: #1  0x0000000000459ed3 in nm_logging_backtrace ()
NetworkManager: No symbol table info available.
NetworkManager: #2  0x0000000000441179 in ?? ()
NetworkManager: No symbol table info available.
NetworkManager: #3  <signal handler called>
NetworkManager: No symbol table info available.
NetworkManager: #4  0x00007f3391ee2285 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
NetworkManager: 
NetworkManager: 
NetworkManager: 
NetworkManager: #5  0x00007f3391ee3b9b in abort () at abort.c:92
NetworkManager: 
NetworkManager: 
NetworkManager: 
NetworkManager: #6  0x0000003f9ec66c0d in g_assertion_message (domain=<optimized out>, file=<optimized out>, line=<optimized out>, func=0x4929d0 "dispose", message=0xc48d20 "assertion failed: (bus)") at gtestutils.c:1358
NetworkManager: 
NetworkManager: 
NetworkManager: #7  0x0000003f9ec67132 in g_assertion_message_expr (domain=0x0, file=0x49036a "nm-manager.c", line=4354, func=0x4929d0 "dispose", expr=<optimized out>) at gtestutils.c:1369
NetworkManager:         s = <optimized out>
NetworkManager: #8  0x0000000000451a7c in ?? ()
NetworkManager: No symbol table info available.
NetworkManager: #9  0x0000003f9f80f833 in g_object_unref (_object=0xc50030) at gobject.c:2697
NetworkManager:         object = 0xc50030 [NMManager]
NetworkManager: 
NetworkManager: 
NetworkManager: #10 0x000000000041c590 in main ()
NetworkManager: No symbol table info available.
NetworkManager: A debugging session is active.
NetworkManager: 
NetworkManager: #011Inferior 1 [process 980] will be detached.
NetworkManager: 
NetworkManager: Quit anyway? (y or n) [answered Y; input not from terminal]
NetworkManager: ******************* END **********************************
invld>Feb  9 14:41:49 64test systemd[1]: NetworkManager.service: main process exited, code=exited, status=1
invld>Feb  9 14:41:49 64test systemd[1]: Unit NetworkManager.service entered failed state.


Second trace:


NetworkManager[957]: <warn> disconnected by the system bus.
NetworkManager[957]: <info> caught signal 15, shutting down normally.
NetworkManager[957]: <info> Updating /etc/hosts with new system hostname
NetworkManager[957]: dbus_g_proxy_new_for_name: assertion `connection != NULL' failed
NetworkManager[957]: <error> [1297259268.889630] [NetworkManagerUtils.c:399] nm_utils_call_dispatcher(): could not get dispatcher proxy!
NetworkManager[957]: <warn> caught signal 6. Generating backtrace...
NetworkManager: ******************* START **********************************
NetworkManager: [Thread debugging using libthread_db enabled]
NetworkManager: [New Thread 0x7fb3628a0700 (LWP 1036)]
NetworkManager: [New Thread 0x7fb3632c1700 (LWP 1010)]
NetworkManager[957]: ******************* START **********************************
NetworkManager[957]: Frame 0: /usr/sbin/NetworkManager (nm_logging_backtrace+0x3b) [0x459d8b]
NetworkManager[957]: Frame 1: /usr/sbin/NetworkManager (0x400000+0x441179) [0x441179]
NetworkManager[957]: Frame 2: /lib64/libpthread.so.0 (0x7fb363f0a000+0x7fb363f194e0) [0x7fb363f194e0]
NetworkManager[957]: Frame 3: /lib64/libc.so.6 (gsignal+0x35) [0x7fb363513285]
NetworkManager[957]: Frame 4: /lib64/libc.so.6 (abort+0x17b) [0x7fb363514b9b]
NetworkManager[957]: Frame 5: /lib64/libglib-2.0.so.0 (g_assertion_message+0x12d) [0x3f9ec66c0d]
NetworkManager[957]: Frame 6: /lib64/libglib-2.0.so.0 (0x3f9ec00000+0x3f9ec67132) [0x3f9ec67132]
NetworkManager[957]: Frame 7: /usr/sbin/NetworkManager (0x400000+0x451a7c) [0x451a7c]
NetworkManager[957]: Frame 8: /lib64/libgobject-2.0.so.0 (g_object_unref+0xe3) [0x3f9f80f833]
NetworkManager[957]: Frame 9: /usr/sbin/NetworkManager (main+0x990) [0x41c590]
NetworkManager[957]: Frame 10: /lib64/libc.so.6 (__libc_start_main+0xed) [0x7fb3634fe2fd]
NetworkManager[957]: Frame 11: /usr/sbin/NetworkManager (0x400000+0x41cfb1) [0x41cfb1]
NetworkManager[957]: ******************* END **********************************
invld>Feb  9 14:47:55 64test systemd[1]: NetworkManager.service: main process exited, code=exited, status=1
invld>Feb  9 14:47:55 64test systemd[1]: Unit NetworkManager.service entered failed state.

Comment 1 Dan Williams 2011-02-21 23:06:46 UTC
I think this is 2ce6f29c2151af3f34976feda6964a21431cdb5f on the NM_0_8 branch.

http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?h=NM_0_8&id=2ce6f29c2151af3f34976feda6964a21431cdb5f

Comment 2 Fedora Update System 2011-02-24 06:05:48 UTC
NetworkManager-0.8.3.995-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.995-1.fc14

Comment 3 Fedora Update System 2011-02-24 06:09:15 UTC
NetworkManager-0.8.3.995-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.995-1.fc13

Comment 4 Fedora Update System 2011-02-24 20:57:01 UTC
NetworkManager-0.8.3.995-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.995-1.fc14

Comment 5 Dan Williams 2011-02-25 06:57:32 UTC
*** Bug 673816 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2011-02-25 23:42:37 UTC
Package NetworkManager-0.8.3.996-1.fc14:
* should fix your issue,
* was pushed to the Fedora 14 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.8.3.996-1.fc14'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.996-1.fc14
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2011-02-25 23:45:38 UTC
Package NetworkManager-0.8.3.996-1.fc13:
* should fix your issue,
* was pushed to the Fedora 13 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.8.3.996-1.fc13'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.996-1.fc13
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2011-03-02 01:48:56 UTC
NetworkManager-0.8.3.996-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-03-03 09:47:02 UTC
Package NetworkManager-0.8.3.997-1.fc13:
* should fix your issue,
* was pushed to the Fedora 13 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.8.3.997-1.fc13'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.997-1.fc13
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2011-03-25 03:29:56 UTC
NetworkManager-0.8.3.998-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.998-2.fc13

Comment 11 Fedora Update System 2011-04-12 21:27:48 UTC
NetworkManager-0.8.3.998-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.