Bug 67638 - System date not checked during install
System date not checked during install
Status: CLOSED RAWHIDE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Greg DeKoenigsberg
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-28 11:56 EDT by Matt Jamison
Modified: 2007-07-31 15:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-19 10:22:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josef Komenda 2002-06-28 11:56:54 EDT
Description of Problem: The date/time on the satellite box needs to be correct,
or the clien machines will be unable to connect, due to cookie errors. Installer
should check the date using rdate -s, prompt the user for a sync source or
something similar, and set the system hostname accordingly. 


Version-Release number of selected component (if applicable): see bug 63780
Comment 1 Adrian Likins 2002-07-01 17:12:29 EDT
I dont like this idea. Asking the user for a host to rdate
to in an installer designed to be as minimal and as easy
as possible seems like a bad idea.

The best fix is to setup ntp. I dont really think this
should be the satellite installers responsibility. Thats
more of a generic sysadmin task that should be performed
by the admin of the box. Plus the probabaly arises of
"where do I ntp to" and more importantly, does the network
allow ntp out? if not it needs to be a local ntp server,
and again, prompting for a ntp server seems weird.
Comment 2 Chip Turner 2002-07-01 18:02:32 EDT
timing is a critical factor for things working; if we can do a cheap check in
the client, even one that may sometimes fail, it will catch the more serious
issues.  Even rdate'ing to time.nist.gov or something.  Just to check to see how
far off the system is from the outside world, and warning.  I agree the
installer shouldn't set up NTP, but it can do some fairly cheap checks, can't it?
Comment 3 Josef Komenda 2002-07-02 10:37:06 EDT
Per GDK, this is something we should clarify in the initial documentation. Over
to him for verbage update in the install docs.
Comment 4 Greg DeKoenigsberg 2002-07-19 10:22:35 EDT
This time sensitivity issue will be well-covered in the docs.  Joe, please
close.

Note You need to log in before you can comment on or make changes to this bug.