Bug 67639 - CUPS fails to print Postscript level 3 files properly
CUPS fails to print Postscript level 3 files properly
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: cups (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-28 12:11 EDT by Manfred Hollstein
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-25 15:23:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manfred Hollstein 2002-06-28 12:11:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.3 (X11; Linux i686; U;) Gecko/20020523

Description of problem:
Printing Postscript level 3 files, generated e.g. via GIMP -> Print to
file, will be printed as plain text instead of using "gs" as a RIP and
printing a graphical image.

Version-Release number of selected component (if applicable):
-1.1.14-15

How reproducible:
Always

Steps to Reproduce:
1.Load graphics into GIMP and print to file selecting Postscript Level 2
2.Print the resulting .ps file to a printer queue driven by CUPS
3.Watch "%!PS-Adobe-3.0..." being printed as literal ASCII text
	

Actual Results:  No graphics will be printed, but rather plain ASCII text only.

Expected Results:  A graphic image should be printed.

Additional info:

FWIW, this is with a HP OfficeJet G85 + hpijs. Also, loading the
generated .ps file into "ggv" and printing it from there, results in
a proper print.
Comment 1 Richard Torkar 2002-09-24 10:16:47 EDT
Hmm probably same type of error here.

I've set up lp2 via Cups to print to a Canon GP 335 using the "Foomatic +
Postscript (en)" driver. I use lpd://IP/queue

When I print the test page pure postscript is getting printed!
The first part of the page looks like this:
%!
<</HWResolutionD600 600E>>setpagedevice
<</Duplex false>>setpagedevice
%!PS-Adobe-3.0
%RBINumCopies: 1
%%Pages: (atend)
%%BoundingBox: 0 0 612 792
and so one...

If I instead chose the "Foomatic + gimp-print (en)" it prints out the
test page correctly. Now this wouldn't be a problem if the gimp-print
driver would have the ability to print in duplex... Seems to me that
only the ps driver has this ability.

I use RedHat Beta null. 
[toor@~]$ rpm -qa | grep cups
cups-drivers-1.9-1.20020617.6
cups-libs-1.1.15-9
cups-1.1.15-9
cups-drivers-hpijs-1.9-1.20020617.6
cups-drivers-pnm2ppa-1.9-1.20020617.6
Comment 2 Manfred Hollstein 2002-10-04 11:11:50 EDT
This was caused by a mis-configuration in GIMP. When I clicked on the
"Setup" button in the "Printer Settings" part of the Print dialog, it
became obvious why literal text had been printed... Removing the "-oraw"
from the options to be passed to the "lp" command resolves my problem.

I'm closing this issue now.

Note You need to log in before you can comment on or make changes to this bug.