Bug 676430 - amavisd-new does not work with systemd
Summary: amavisd-new does not work with systemd
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: amavisd-new
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Steven Pritchard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-09 20:27 UTC by Nicolas Mailhot
Modified: 2011-10-02 23:06 UTC (History)
4 users (show)

Fixed In Version: amavisd-new-2.6.6-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-02 18:15:37 UTC


Attachments (Terms of Use)

Description Nicolas Mailhot 2011-02-09 20:27:50 UTC
Description of problem:

In fedora devel (just about to become F15alpha) :
# systemctl status amavisd.service
amavisd.service - LSB: amavisd is an interface between MTA and content checkers
	  Loaded: loaded (/etc/rc.d/init.d/amavisd)
	  Active: active (exited) since Wed, 09 Feb 2011 21:17:17 +0100; 8min ago
	 Process: 3202 ExecStop=/etc/rc.d/init.d/amavisd stop (code=exited, status=2/INVALIDARGUMENT)
	 Process: 3229 ExecStart=/etc/rc.d/init.d/amavisd start (code=exited, status=0/SUCCESS)
	Main PID: 3234 (code=exited, status=0/SUCCESS)
	  CGroup: name=systemd:/system/amavisd.service

Probably due to

# rpm -V amavisd-new5S.T.....  c /etc/amavisd/amavisd.conf
5S.T.....  c /etc/clamd.d/amavisd.conf
missing     /var/run/amavisd

# mount |grep run
tmpfs on /var/run type tmpfs (rw,nosuid,nodev,noexec,relatime,rootcontext=system_u:object_r:var_run_t:s0,seclabel,mode=755)
Version-Release number of selected component (if applicable):

⇒ with systemd /var/run is a tmpfs so packages that need subdirs inside need to be modified to tell systemd to create them

See also
http://fedoraproject.org/wiki/Tmpfiles.d_packaging_draft

How reproducible:
always

Additional info:
amavisd-new-2.6.4-2.fc15.noarch
systemd-units-17-3.fc15.x86_64
systemd-gtk-17-3.fc15.x86_64
systemd-17-3.fc15.x86_64

Comment 1 Anthony Messina 2011-06-09 03:26:12 UTC
Please add amavisd.conf to /etc/tmpfiles.d in the amavisd-new package:

/etc/tmpfiles.d]# cat amavisd.conf
d       /var/run/amavisd        0755 amavis amavis

Comment 2 Fedora Update System 2011-09-19 02:40:00 UTC
amavisd-new-2.6.6-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/amavisd-new-2.6.6-1.fc15

Comment 3 Fedora Update System 2011-09-19 02:40:53 UTC
amavisd-new-2.6.6-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/amavisd-new-2.6.6-1.fc16

Comment 4 Fedora Update System 2011-09-19 18:31:43 UTC
Package amavisd-new-2.6.6-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing amavisd-new-2.6.6-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/amavisd-new-2.6.6-1.fc16
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2011-10-02 18:14:59 UTC
amavisd-new-2.6.6-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2011-10-02 23:06:14 UTC
amavisd-new-2.6.6-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.