Bug 676432 - Can't search for subscriptions in gui on stage
Summary: Can't search for subscriptions in gui on stage
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Chris Duryee
QA Contact: J.C. Molet
URL:
Whiteboard:
: 676611 (view as bug list)
Depends On:
Blocks: Entitlement-Beta
TreeView+ depends on / blocked
 
Reported: 2011-02-09 20:38 UTC by J.C. Molet
Modified: 2011-02-23 21:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-23 21:51:30 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description J.C. Molet 2011-02-09 20:38:57 UTC
Description of problem:
When using subscription manager on the stage environment using the latest rhsm entitlement beta release candidate, you cannot find any subscriptions using the search feature in the gui or in the compliance assistant.

Version-Release number of selected component (if applicable):
subscription-manager-gnome-0.93.19-1.el6.x86_64
subscription-manager-firstboot-0.93.19-1.el6.x86_64
python-rhsm-0.94.15-1.el6.noarch
subscription-manager-0.93.19-1.el6.x86_64

Steps to Reproduce:
1. Install rhsm and rhel6 from the entitlement beta release candidate: http://download.lab.bos.redhat.com/devel/candidate-trees/RHEL-6-Entitlement-Beta-RC2.0/
2. Create a user on access.stage.redhat.com and activate a subscription
3. set hostname=subscriptions.rhn.stage.redhat.com in /etc/rhsm/rhsm.conf
4. register subscription manager with that user
5. Search for subscriptions
  
Actual results:
No subscriptions can be found using any of the search filters.

Expected results:
Subscriptions can be found

Additional info:
This works perfectly in the command line version and when using the auto-subscribe on the register dialog.

Comment 1 Chris Duryee 2011-02-09 20:43:43 UTC
did a subscription-manager clean, no effect

Comment 2 Chris Duryee 2011-02-09 20:52:56 UTC
in stage, this returns a null set:

/pools?consumer=9510e6cb-b57f-4f41-92d8-8dca5dfeee0d&activeon=20110209

but this returns the right data:

/pools?consumer=9510e6cb-b57f-4f41-92d8-8dca5dfeee0d

looking more...

Comment 3 Chris Duryee 2011-02-09 21:55:21 UTC
this is the same bug as https://bugzilla.redhat.com/show_bug.cgi?id=674078. I associated with the entitement beta, we should be all squared away now.

marking as modified for now

Comment 5 John Sefler 2011-02-10 04:53:06 UTC
Installed latest compose for Entitlement Beta:
http://download.devel.redhat.com/devel/candidate-trees/RHEL6.0-Entitlement-20110209.0/

Installed versions of subscription-manager packages:
[root@jsefler-betastage-2 ~]# rpm -qa | grep subscription-manager
subscription-manager-firstboot-0.93.19-1.el6.x86_64
subscription-manager-0.93.19-1.el6.x86_64
subscription-manager-gnome-0.93.19-1.el6.x86_64
[root@jsefler-betastage-2 ~]# rpm -qa | grep python-rhsm
python-rhsm-0.94.16-1.el6.noarch

^^^ Notice python-rhsm is now a newer version.

The search functionality for subscriptions on the subscription-manager-gui All Available Subscriptions tab now retrieves the expected subscriptions.

Moving to VERIFIED

Comment 6 John Sefler 2011-02-10 15:58:50 UTC
The candidate-tree link tested in Comment #5 was renamed to:
http://download.devel.redhat.com/devel/candidate-trees/RHEL-6-Entitlement-Beta-RC3.0/

Comment 7 John Sefler 2011-02-10 16:22:38 UTC
*** Bug 676611 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.