Bug 676483 - nss-pam-ldapd: troff syntax error in the man page of nslcd
nss-pam-ldapd: troff syntax error in the man page of nslcd
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: 6.1
Assigned To: Ivana Varekova
BaseOS QE - Apps
: ManPageChange
Depends On:
Blocks: 692496
  Show dependency treegraph
 
Reported: 2011-02-09 21:14 EST by Subin Francis
Modified: 2013-04-02 19:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 692496 (view as bug list)
Environment:
Last Closed: 2011-04-18 08:26:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for build-time (449 bytes, patch)
2011-02-18 15:36 EST, Nalin Dahyabhai
no flags Details | Diff

  None (edit)
Description Subin Francis 2011-02-09 21:14:04 EST
Description of problem:

With RHEL6.0 GA, I am getting "Error parsing *roff command from file /usr/share/man/man8/nslcd.8.gz" in the man page of nslcd

Version-Release number of selected component (if applicable): RHEL 6.0


How reproducible:

Just run "man nslcd |& head" from shell.

Actual results:

------------
Error parsing *roff command from file /usr/share/man/man8/nslcd.8.gz
nslcd(8)                    System Manager’s Manual                   nslcd(8)



NAME
       nslcd - local LDAP name service daemon.

SYNOPSIS
       nslcd [ options ]

------------

Expected results:

It should not throw any troff syntax error.
Comment 3 Ivana Varekova 2011-02-18 05:12:21 EST
The manual page is a part of nss-pam-ldapd package.
Comment 4 Arthur de Jong 2011-02-18 06:22:01 EST
The nslcd manual page is generated from docbook XML (using docbook2x-man) in the source tarball. It should fall back to the included troff files built as part of the release if docbook2x-man isn't available.

The troff files included in the tarball work correctly on Debian.
Comment 5 Nalin Dahyabhai 2011-02-18 15:30:39 EST
We don't list docbook2x-man as a build-time requirement, so it turns out that we're not actually rebuilding the man page.  The man command appears to be tripping up on the first line in the file ('\" -*- coding: utf-8 -*-).  When I run Fedora's db2x_docbook2man command on the .xml file, I get something similar, but that initial single quote turns into a period (.\" -*- coding: us-ascii -*-), which 'man' seems to handle better.

The package containing that command isn't in RHEL, though, so we can't do that.  The man-db package, which replaces man in recent Fedora releases, also handles both versions of the file without problems, so in future releases this isn't an issue.  So I guess the simplest thing is to patch that character from the tarball's man page when we compile for 6.x.
Comment 6 Nalin Dahyabhai 2011-02-18 15:36:21 EST
Created attachment 479603 [details]
patch for build-time
Comment 7 Nalin Dahyabhai 2011-03-02 16:59:00 EST
This affects nslcd.conf(5) as well.  However we work around this, we should make sure we get both.
Comment 15 Ivana Varekova 2011-04-18 08:26:30 EDT
The man page is already fixed in 692496, now this bug is removed from man-pages-overrides errata. I'm closing this bug (notabug).

Note You need to log in before you can comment on or make changes to this bug.