Bug 676536 - rhel3.9 can not find file in cdrom
rhel3.9 can not find file in cdrom
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Markus Armbruster
Virtualization Bugs
:
Depends On: 667611
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2011-02-10 02:15 EST by Suqin Huang
Modified: 2013-01-09 18:32 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 667611
Environment:
Last Closed: 2011-08-09 07:14:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 1 Suqin Huang 2011-02-10 02:16:20 EST
kernel: 2.6.18-238.el5
kvm: kvm-83-225.el5
Comment 3 Markus Armbruster 2011-08-08 12:02:58 EDT
We've fixed a bunch of CD-ROM issues since comment#1, e.g. bug 652135.  Could
you retest?
Comment 4 Xiaoqing Wei 2011-08-09 01:08:26 EDT
(In reply to comment #3)
> We've fixed a bunch of CD-ROM issues since comment#1, e.g. bug 652135.  Could
> you retest?

Hi Markus,

I am using kvm-83-239 / kernel-2.6.18-269 . 

boot guest with 3 ide devices (one hard_drive, two cdroms)
index=0 for hard_drive , index=1 for the rhel3.9 installation iso, index=2 for ks.iso

rhel3.9-32 installer still cannot find  ks file . 

here's the cmd:

qemu-kvm -name 'rhel3.9-32' -monitor stdio -serial unix:'/172541-Q7Pt',server,nowait \
\
-drive file='/RHEL-3.9-32.qcow2',index=0,if=ide,media=disk,cache=none,format=qcow2 \
\
-net nic,vlan=0,model=e1000,macaddr='9a:d9:12:d5:10:e0' -net tap,vlan=0,ifname='rhel39-32' -m 4096 -smp 2,cores=1,threads=1,sockets=2 \
\
-drive file='/RHEL3.9-i386-DVD.iso',media=cdrom,index=1 \
\
-drive file='/ks.iso',media=cdrom,index=2 \
\
-cpu qemu64,+sse2 -soundhw ac97  -vnc :0 -rtc-td-hack -M rhel5.6.0 -boot d  -usbdevice tablet -no-kvm-pit-reinjection
Comment 5 Markus Armbruster 2011-08-09 02:28:07 EDT
That was quick, thanks!
Comment 6 Markus Armbruster 2011-08-09 05:48:54 EDT
What about RHEL-6, RHEL-5 and RHEL-4 guests?  Can they find their kickstart file?
Comment 7 Xiaoqing Wei 2011-08-09 06:25:54 EDT
(In reply to comment #6)
> What about RHEL-6, RHEL-5 and RHEL-4 guests?  Can they find their kickstart
> file?

they can load their own kickstart files happily :)

Note You need to log in before you can comment on or make changes to this bug.