Bug 67664 - Redhat 7.3: emacs indentation in C mode incorrect.
Summary: Redhat 7.3: emacs indentation in C mode incorrect.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: emacs (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-28 18:33 UTC by phil
Modified: 2007-04-18 16:43 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-28 18:33:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description phil 2002-06-28 18:33:22 UTC
Description of Problem: Redhat 7.3: emacs indentation in C mode incorrect.

Version-Release number of selected component (if applicable):
GNU Emacs 21.2.1

How Reproducible:
Always.

Steps to Reproduce:
1. use 'emacs foo.c' to edit a .c file. 
2. within a function, hit tab to indent.
3. 

Actual Results:
it indents 8 spaces.

Expected Results:
In C mode, indent 2 spaces, in each set of braces.
On Redhat 7.2 and prior, (emacs 20.7.1), it does this.

Additional Information:	

Thanks.

Phil Kaslo
phil@cs.arizona.edu

Comment 1 Trond Eivind Glomsrxd 2002-06-28 19:07:29 UTC
The amounts of space and other behaviour are completely customizable - look at
the info pages: hit "m CC Mode<ENTER>" for more information.

Comment 2 phil 2002-06-28 20:56:35 UTC
I (and the user here that reported the problem) tried
 alt-m m CC Mode<ENTER>
and the response was
  No manual entry for CC Mode

I copied the emacs binary and /usr/share/emacs/20.7 directory from Redhat 7.1
to his machine, now running 7.3.  He's happy using that.

Thanks.
Phil Kaslo


Comment 3 Trond Eivind Glomsrxd 2002-06-28 21:23:09 UTC
Infopages are accessed through C-h i

Comment 4 phil 2002-06-28 21:37:46 UTC
'Control-h i' just moves me up one line in the file,
and inserts the character i.

Phil


Comment 5 Trond Eivind Glomsrxd 2002-06-28 21:54:03 UTC
Just run info - I'll stop here, this is a bug report facility, not a support
channel. The above is not a bug, but a configuration issue.

Comment 6 phil 2002-06-28 22:05:05 UTC
Thanks.
Phil



Note You need to log in before you can comment on or make changes to this bug.