Bug 676699 - thunderbird-lightning add-on not compatible with thunderbird
Summary: thunderbird-lightning add-on not compatible with thunderbird
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: sunbird
Version: el6
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-10 20:24 UTC by Dave Botsch
Modified: 2012-04-12 11:34 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-12 11:34:37 UTC
Type: ---


Attachments (Terms of Use)

Description Dave Botsch 2011-02-10 20:24:52 UTC
Description of problem:

Under RHEL6/64-bit, thunderbird says that the thunderbird-lightning add-on from the rpm is not compatible with thunderbird 3.x


Version-Release number of selected component (if applicable):

thunderbird-lightning-1.0-0.21.20090916hg.el6.x86_64
thunderbird-3.1.7-3.el6_0.x86_64

How reproducible:

100% of the time

Steps to Reproduce:
1. install thunderbird x86_64 rpm
2. install thunderbird-lightning x86_64 rpm
3. start thunderbird
4. go to add-ons dialog
5. dialog shows that lightning 1.0b2 is not compatible w. thunderbird 3.1.x
  
Actual results:

thunderbird-lightning does not work

Expected results:

thunderbird-lightning does work

Additional info:

I grabbed the 64-bit lightning.xpi from 

http://releases.mozilla.org/pub/mozilla.org/calendar/lightning/releases/1.0b2/contrib/linux-x86_64/

which works great.

Comment 1 David Ward 2011-02-21 00:30:28 UTC
This is a duplicate of bug 668513.

Comment 2 David Ward 2011-02-21 01:03:15 UTC
@Lubomir:

Fedora 14 contains a version of Lightning that is compatible with Thunderbird 3.1.7.  However, in Fedora 14 the "thunderbird-lightning" RPM was recently moved into the "thunderbird" package out of the "sunbird" package, where it is in EPEL 6 now.

RHEL already has a "thunderbird" package.  Is it a conflict to have a "thunderbird" package in EPEL as well, which only builds thunderbird-lightning?

If that is not a problem, then the "thunderbird" package from Fedora 14 should be copied into EPEL, except that building the "thunderbird" RPM itself should be disabled.

Comment 3 David Ward 2011-02-21 01:04:08 UTC
Sorry I meant the previous comment to go on bug 668513. Please mark this one as the duplicate.

Comment 4 Pierre Larsson 2011-05-11 14:57:50 UTC
Same issue occurs on i386.

Comment 5 David Ward 2011-05-12 13:59:57 UTC
@Lubomir: You have not responded to this bug report since it was opened three
months ago. Please respond if you are still maintaining the sunbird package.
Otherwise I will ask FESco to take over this package, following the process
described in:
http://fedoraproject.org/wiki/Policy_for_nonresponsive_package_maintainers

--

@Pierre: please see updates I posted to bug 668513.

Comment 6 David Ward 2011-05-21 14:51:40 UTC
SECOND TRY -- @Lubomir: You have not responded to this bug report since it was
opened three months ago. Please respond if you are still maintaining the sunbird
package. Otherwise I will ask FESco to delete this package, following the
process described in: http://fedoraproject.org/wiki/Policy_for_nonresponsive_package_maintainers

Comment 7 Taunus 2011-08-30 11:29:18 UTC
Lubomir says here https://bugzilla.redhat.com/show_bug.cgi?id=668513:
"Uh, sorry for my non-responsiveness. I am not able to maintain Sunbird any more
and am orphaning the package."

Anyway, there is this package:
thunderbird-lightning-1.0-0.42.b3pre.fc14.src.rpm
http://koji.fedoraproject.org/koji/buildinfo?buildID=259045

It can be recompiled for el6 and it works ok with rhel 6.1 and thunderbird 3.1.12.

So could somebody with access to epel just rebuild it for epel.el6 ?

Comment 8 Taunus 2011-08-30 11:30:57 UTC
Oh,

there is an el6 version:
http://koji.fedoraproject.org/koji/buildinfo?buildID=239998

Comment 9 John Hodrien 2011-09-16 14:33:53 UTC
So given there's a version that works for EL6, what's holding up getting it into EPEL?

Comment 10 Thomas Nail 2011-12-12 19:35:20 UTC
The EL6 version seems to have been deleted from:

http://koji.fedoraproject.org/koji/buildinfo?buildID=239998

FWIW - the FC14 build seems to work on EL6 (from http://koji.fedoraproject.org/koji/buildinfo?buildID=259045), but it would be nice to have the package ported and available in an "official build" on EL6.

Comment 11 Ghislain Vaillant 2011-12-15 12:38:00 UTC
And as Dave Botsch originally mentioned, the non-working version of thunderbird-lightning in EPEL is useless and should not be available. It annoys and confuses more than it serves anything.

Indeed, the extension available here does work.

http://releases.mozilla.org/pub/mozilla.org/calendar/lightning/releases/1.0b2/contrib/linux-x86_64/

However, to my knowledge, there is no official documentation that points to this procedure. So the regular user might just give up the installation of the calendar extension. 

Since it appears that a working package has been built (from Fedora 14 ?), what's missing for getting it to replace the currently non-working one ?

Comment 12 Jan Horak 2012-04-12 11:34:37 UTC
The thunderbird-lightning is no longer part of sunbird package. There is separate thunderbird-lightning package, please reopen if problem reoccurs.


Note You need to log in before you can comment on or make changes to this bug.