Bug 676815 - Upgrade from F14 to F15 Alpha TC1 failed due to package conflicts
Upgrade from F14 to F15 Alpha TC1 failed due to package conflicts
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F15Beta/F15BetaBlocker
  Show dependency treegraph
 
Reported: 2011-02-11 06:38 EST by He Rui
Modified: 2011-03-02 22:02 EST (History)
7 users (show)

See Also:
Fixed In Version: systemd-18-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-02 22:02:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (9.02 KB, application/octet-stream)
2011-02-11 06:38 EST, He Rui
no flags Details
F-15 Alpha RC2 x86_64 anaconda log (10.86 KB, text/plain)
2011-02-28 21:38 EST, Hongqing Yang
no flags Details

  None (edit)
Description He Rui 2011-02-11 06:38:33 EST
Created attachment 478221 [details]
anaconda.log

Description of problem:
upgrade F14 using anaconda 15.19 of F15 Alpha TC1. At package installation step, error occurred and stopped install. In anaconda.log(attached), it said:

11:26:24,137 ERR anaconda: package conflicts: upstart-sysvinit conflicts with systemd-17-2.fc15.i686
11:26:24,137 ERR anaconda: package conflicts: systemd-sysvinit conflicts with (installed) upstart-sysvinit-0.6.5-10.fc14.i686

Version-Release number of selected component (if applicable):
systemd-17-2.fc15.i686

How reproducible:
100%

Steps to Reproduce:
1. Upgrade F-14 system using F15-Alpha-TC1 DVD
2. Error occurred at package installation step
  
Expected results:
Upgrade successfully
Comment 1 James Laska 2011-02-11 11:41:27 EST
Adding to F15Beta tracker per the following Beta release criteria:

   "The installer must be able to successfully complete an upgrade 
    installation from a clean, fully updated default installation
    of the previous stable Fedora release, either via preupgrade 
    or by booting to the installer manually"

https://fedoraproject.org/wiki/Fedora_15_Beta_Release_Criteria
Comment 2 Lennart Poettering 2011-02-14 13:26:32 EST
I am not sure how this is a bug? Yes, these two packages conflict. You cannot install Upstart and systemd at the same time as /sbin/init. No news here.

What are you asking me to do here?
Comment 3 Bill Nottingham 2011-02-14 14:03:46 EST
I think the Obsoletes may need adjusted to properly obsolete whatever's in F-14... perhaps upstart was updated there and they no longer trigger.
Comment 4 Bill Nottingham 2011-02-14 14:27:55 EST
Fixed in -6.
Comment 5 Fedora Update System 2011-02-14 15:16:07 EST
systemd-17-6.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/systemd-17-6.fc15
Comment 6 Fedora Update System 2011-02-15 12:27:57 EST
systemd-17-6.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update systemd'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/systemd-17-6.fc15
Comment 7 Fedora Update System 2011-02-16 16:58:16 EST
systemd-18-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/systemd-18-1.fc15
Comment 8 James Laska 2011-02-17 08:30:25 EST
*** Bug 678201 has been marked as a duplicate of this bug. ***
Comment 9 Hongqing Yang 2011-02-28 21:38:19 EST
reproduced in F-15 Alpha RC2
Comment 10 Hongqing Yang 2011-02-28 21:38:54 EST
Created attachment 481483 [details]
F-15 Alpha RC2 x86_64 anaconda log
Comment 11 Fedora Update System 2011-03-02 22:02:26 EST
systemd-18-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.