Bug 67685 - SB Live! non-functional
SB Live! non-functional
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-06-29 04:53 EDT by Chris Kloiber
Modified: 2007-03-26 23:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-06-08 12:37:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Chris Kloiber 2002-06-29 04:53:38 EDT
Description of Problem: 
Received a call from a Dell Pre-Install customer running Red Hat 7.3 with the 
2.4.18-4 kernel. emu10k1 driver appears loaded and in use according to lsmod, 
she couldn't get any sounds out of it. I had her check the volume both in 
aumix and manually, had her try the speakers on another system (Windows, they 
work) and in both the front and back speaker channel of the card. 
Card identified as: 
00:0c.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 08) 
00:0c.0 Class 0401: 1102:0002 (rev 08) 
Just so happens I have an identical Card (PCI:ID matches exactly) here. 
Popped it in a system and it won't work either. On my system here at 
Centennial, I tried both the 2.4.18-3smp and 2.4.18-5smp kernels, as well as 
both the emu10k1 and emu10k1_old modules in -5smp. The driver loads, but no 
sound. No error messages that I could find, other than my own brain damage 
attempting to load one module while the other was still loaded. Usage count 
goes up every time you try to play something, and never goes back down even 
though the 'play /usr/share/sounds/phone.wav' command returns. I can loan the 
card if needed.
Comment 1 Dave Gotwisner 2002-07-09 13:11:05 EDT
From the description above, I don't know if the original user got no sound, or
just didn't get sound with an audio-cd.  What I discovered is that I got no
sound originally (ie, after installing RH7.3), but when I did a sndconfig (as
root) manually from a shell), I then started getting sound.  Unfortunately, I
still can't play audio CDs (aumix shows Vol / Pcm / Spkr / Line / Mic / CD /
IGain / OGain / Line1 / Digital1 / PhoneIn / PhoneOut / Video, but no Pcm2).
Comment 2 Chris Kloiber 2002-07-09 13:58:47 EDT
The customer was geting no sound at all. If you are getting sound, but not CD
audio, make sure you have the 3-4 wire analog audio cable installed. I don't
believe our driver can pull audio off the data lines, but I could be mistaken.
Comment 3 Dave Gotwisner 2002-07-09 14:53:15 EDT
In my case, the system dual boots between windows XP and Linux (RH7.3).  If I
boot to XP, the CD player works fine to the speakers, so I know that everything
is physically hooked up correctly.  If I boot to Linux, sound works if I run
programs that use sound, but running the Gnome CD player or XMMS fail to play
anything.  Gnome CD player detects that there is an audio CD, I can display the
track information, and if I press play, I see the timer counting up (and moving
from track to track); I just get nothing coming out the speaker.  I have tried
several CDs, all of which play fine on XP on the exact same hardware.  In the XP
case, since I had to reload to partition the disk, I am using the stock MS
drivers, not even the soundblaster driver which comes on a separate CD from

I also run VMware from under Linux, and it is also able to play sounds (although
not CDs) when running XP under VMware under Linux.
Comment 4 Need Real Name 2002-07-10 13:42:22 EDT
I am having a similar but slightly different problem.  I get sound, but only
from CD - and the volume levels are totally controllable from GMIX.  I cannot
play anything from the HD, and when I try to play an MP3 in XMMS, it flies by at
super speed.  I'd like to know how you got it to play from software - I'd rather
use MP3s than CDs.
Comment 5 Arjan van de Ven 2002-07-10 13:46:01 EDT
The "super speed" thing I've only seen with KDE;
if you use xmms please try using the "OSS plugin" backend with /dev/dsp as device
Comment 6 Need Real Name 2002-07-10 14:07:12 EDT
Unfortunately I still have the same problem.  Super speed playback with no
sound.  Could this be an issue with ESD?
Comment 7 Alan Cox 2003-06-08 12:37:33 EDT
EMU10K (aka SB Live) should be ok in current errata if not please re-open. Thanks

Note You need to log in before you can comment on or make changes to this bug.